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ABOUT THIS COURSE
Since you’ve probably completed the first course, or are familiar with the basics of building
and modifying reports, you’re ready to move ahead to create complex reports and data sources
using Crystal Reports’ tools. In this course, you’ll not only learn how to create more sophisti-
cated reports like subreports and cross-tabs, you’ll also learn how to increase the speed and
efficiency of your reports by using SQL queries and dictionaries.

Even though Crystal Reports is one of the most powerful report-generating applications avail-
able, it is also one of the easiest to use. By taking the time to learn how to use some of
Crystal Reports’ tools, you won’t be slowed down by large databases or databases that you’re
unfamiliar with. By creating subreports, cross-tabs, and running totals, you’ll turn raw data into
meaningful customized reports that will help your business run more smoothly. If you work
with large databases, you may find yourself faced with performance issues. In this course, you
will also learn to use tools that can increase the speed in which data is retrieved.

Course Description
Target Student
This course is designed for people who know how to create basic list and group reports and
need to create reports that include subreports, cross-tabs, advanced formulas, and charts based
on more than one data series. They may also need to build tools to make it easier for other
people to create reports. They may or may not have programming and/or SQL experience.

Course Prerequisites
Crystal Reports 10.0: Level 1, and knowledge of programming and/or SQL would be helpful.

INTRODUCTION

Introduction vii
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How to Use This Book

As a Learning Guide
Each lesson covers one broad topic or set of related topics. Lessons are arranged in order of
increasing proficiency with Crystal Reports 10.0; skills you acquire in one lesson are used and
developed in subsequent lessons. For this reason, you should work through the lessons in
sequence.

We organized each lesson into results-oriented topics. Topics include all the relevant and sup-
porting information you need to master Crystal Reports 10.0, and activities allow you to apply
this information to practical hands-on examples.

You get to try out each new skill on a specially prepared sample file. This saves you typing
time and allows you to concentrate on the skill at hand. Through the use of sample files,
hands-on activities, illustrations that give you feedback at crucial steps, and supporting back-
ground information, this book provides you with the foundation and structure to learn Crystal
Reports 10.0 quickly and easily.

As a Review Tool
Any method of instruction is only as effective as the time and effort you are willing to invest
in it. In addition, some of the information that you learn in class may not be important to you
immediately, but it may become important later on. For this reason, we encourage you to
spend some time reviewing the topics and activities after the course. For additional challenge
when reviewing activities, try the “What You Do” column before looking at the “How You Do
It” column.

As a Reference
The organization and layout of the book make it easy to use as a learning tool and as an after-
class reference. You can use this book as a first source for definitions of terms, background
information on given topics, and summaries of procedures.

Course Objectives
In this course, you will create complex reports and data sources using Crystal Reports’ tools.

You will:

• create running totals in a report.

• build cross-tabs in your report.

• add subreports to a report.

• design a report that uses a drill-down.

• improve processing speed in your reports.

• chart single and multiple data series.

• report from Excel data.

• insert a geographic map.

INTRODUCTION
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Course Requirements

Hardware
• A Pentium II or higher processor.

• 350 MB of hard-disk space.

• 128 MB of RAM (256 MB RAM recommended).

• Either a local CD-ROM drive, DVD drive, or access to a networked CD-ROM drive.

Software
• Microsoft Windows XP, 2000 SP4, or above.

• A complete installation of Crystal Reports 10.0.

• A default installation of Excel 2000 or newer.

• An installed printer driver. (Printers are not required; however, each PC must have an
installed printer driver in order to use Print Preview.)

Class Setup
This course was written using Crystal Reports 10.0 Professional Edition and Microsoft Windows XP.

1. Install a Custom copy of Crystal Reports 10.0. (On the Selected Features page, click the
Geographic Mapping option and choose Entire Feature Will Be Installed On Local Hard
Drive.)

2. If necessary, reboot your computer.

3. Install a Complete copy of Microsoft Excel 2000 or newer.

4. If necessary, download and install WinZip, which is available at www.winzip.com/.

5. Install a printer driver. A printer isn’t necessary for class, but you must have a printer
driver installed.

6. On the course CD-ROM, run the self-extracting file named 085516dd.exe. This will install
a folder named 085516Data on your C drive. This folder contains the data files you will
need to complete this course.

7. Copy the xtreme.mdb database file from C:\Program Files\Crystal Decisions\Crystal
Reports 10\Samples\En\Databases to the C:\085516Data folder.

The xtreme.mdb file is supplied with Crystal Reports. If this file does not exist in the directory specified, it
may have been copied to another directory in the file installation. If you are unable to locate this file, it will
be on the Crystal Reports installation CD.

8. This is an optional step. Use the following steps to set the location (if you store the
085516Data folder in a location other than the C drive):

a. Launch Crystal Reports, and open the first report in the 085516Data folder.

b. Choose Database→Set Datasource Location to display the Set Datasource Location
dialog box. In the Current Data Source list box, select the first table.

INTRODUCTION
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c. In the Replace With list box, select the option that matches the data type (such as
database files or ODBC), and then browse to the location of the table (if necessary).

d. Click Update.

e. Repeat for each additional report in the 085516Data folder.

9. Staged data files have been provided with this course. These files may help you find a
possible solution if you get stuck at any point during the course. If you wish to use the
staged data files on the course CD-ROM, run the 085516ddstaged.exe self–extracting file
located within. This will install a folder named 085516Staged on your C: drive.

In the 085516Staged folder on your computer, the Lesson folders contain all the course
images and data, completed up to the lesson indicated by the folder name. For example, if
you would like to view the course data as it should appear at the beginning of Lesson 4,
you should open the Lesson 4 folder in the 085516Staged folder on your computer.

10. In addition to the specific setup procedures needed for this class to run properly, you
should also check the Element K Press product support Web site at http://
support.elementkcourseware.com for more information. Any updates about this course
will be posted there.

List of Additional Files
Printed with each activity is a list of files students open to complete that activity. Many activi-
ties also require additional files that students do not open, but are needed to support the file(s)
students are working with. These supporting files are included with the student data files on the
course CD-ROM or data disk. Do not delete these files.

INTRODUCTION
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Creating Running Totals

Lesson Objectives:
In this lesson, you will create running totals in a report.

You will:

• Create a running total field.

• Modify a running total field.

• Create a manual running total on detail data.

• Create a manual running total on summary data.

Lesson Time
1 hour(s), 15 minutes to
1 hour(s), 45 minutes

LESSON 1

LESSON 1

Lesson 1: Creating Running Totals 1
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Introduction
You have already presented totals as summary information appearing at the bottom of a report
and/or in a group section. Another way to create specialized summaries is to use running
totals. In this lesson, you’ll create manual and running totals.

Running totals are helpful because they produce a continual incremental total of data on your
report. Continuous running totals can be helpful in many situations, including inventory con-
trol, sales tracking, and budgeting cash flow. Suppose you wanted a running total in your
report. You could count or use a calculator but that would take a lot of time. A better way is
Crystal Reports’ running total command.

Figure 1-1: You can easily display a running total in your reports.

Running Totals Displayed in a
Report

LESSON 1

Crystal Reports 10.0: Level 22
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TOPIC A
Create a Running Total Field
You already know how to group data and generate subtotals by group. There might be times
when you need a running total displayed on a record-by-record basis. In this topic, you’ll dis-
play a total that evaluates each record and provides a running sum of all the values in a field.

At some point, you’ll have a list of ungrouped data and only want to subtotal some of the data
in the list. For example, if you have a list that contains both Florida and New York customers
and you want a total of the values from just the New York customers and also a total of the
values of Florida customers. You can create a running total for each to maintain separate run-
ning totals.

Figure 1-2: A running total field allows you to easily add running totals to your
reports.

Running Total
Definition:

A running total is a value that is displayed for each record, and that totals all records
in the report or group, up to and including the current record. You can use Crystal
Reports’ running total field or create your own manual running total. A running total
name can contain mixed characters and spaces. After the running total field is created,
Crystal Reports precedes the running total field with a pound sign (#).

Example:
Figure 1-3 shows an example of a running total in a basic list report, based on order
amount.

A Running Total Field

LESSON 1
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Figure 1-3: An example of a running total in a basic list report.

How to Create a Running Total Field
Procedure Reference:

To create a running total field:

1. In the Field Explorer, select Running Total Fields and click the New button to
display the Create Running Total Field dialog box.

2. Type a name for the running total field.

• You can use the default name given by Crystal Reports or create your own
name.

• Names can contain mixed case characters and spaces.

• Crystal Reports assigns a pound sign (#) to running total field names.

3. From the Available Tables And Field column, select the field to summarize.

4. From the Type Of Summary drop-down list, select the type of summary you want
to perform. The available summary types include sum, average, minimum, maxi-
mum, count, and about a dozen others.

5. In the Evaluation section, specify criteria to determine which data the running
total field performs its evaluation on.

6. In the Reset section, specify an option to determine when, or whether, the running
total value is reset.

LESSON 1

Crystal Reports 10.0: Level 24



FO
R 

EV
AL

UA
TI

O
N 

US
E 

O
NL

Y

DO
 N

O
T 

DU
PL

IC
AT

E

(C
) 2

00
4

El
em

en
t K

Co
nt

en
t L

LC

7. Click OK.

8. Insert the field into the report.

9. If you want to adjust the field or label formatting, you can do so in either Design
or Preview view. It is often useful to apply formatting while previewing the report
so that you can see how the formatting affects the report data.

10. If the new field’s label doesn’t align with other field labels, then you can select
all the labels you want to align, then choose the appropriate alignment option
from the Format→Align submenu, or right-click and select from the shortcut
menu’s Align submenu.

• If you want to select some, but not all, of the items within the section, then
you can Ctrl-click, Shift-click, or drag a marquee that touches each object
you want to select.

• If you want to select all items within the section, then you can right-click the
gray area at the left of the section, and select Select All Section Objects.

ACTIVITY 1-1
Creating a Running Total Field

Data Files:

• RT-Saddle Sales.rpt

Setup:
Crystal Reports is running. Data files have been installed in the C:\085516Data folder. The Set
Location is set to the C:\085516Data\xtreme.mdb path.

Scenario:
You work for a company that sells bicycles and equipment, and you’re in charge of inventory
for bicycle saddles. Orders are piling up, and you need to set up a delivery schedule with your
supplier. To make sure you’re not overstocked or short, you want to see the cumulative run-
ning total of saddle quantities sold, along with the detail items. That way you can quickly spot
any unusually large orders.

If you were to just look at the total number ordered per week, for example, you might end up
setting a delivery schedule that doesn’t really meet your needs. One unusually large order
could impact the averages greatly.

Tell students that because of
different computer monitors
and workstation settings, they
might notice that fields are cut
off and fonts look different
than the instructor station.
This is expected and students
will need to be prepared to
adjust their field sizes and
fonts accordingly.
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What You Do How You Do It

1. In the RT-Saddle Sales.rpt report,
create a running total field.

a. Open RT-Saddle Sales.rpt.

b. In the Field Explorer, select Running

Total Fields.

c. Click the New button .

d. In the Running Total Name box, type

SaddleRT

e. In the Available Tables And Fields list box,
select Orders_Detail.Quantity.

f. Click the arrow button to the left of the

Field To Summarize section.

g. Verify that Type Of Summary is set to

Sum.

h. Verify that in the Evaluate section, the

For Each Record option is selected.

i. Verify that in the Reset section, the

Never option is selected.

j. Click OK.

2. Place the new running total field on

the Design tab and label it Running
Total

a. Drag the SaddleRT running total field to

the Details section at the 4.5-inch mar-

gin position.

b. Change the field label to Running Total
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3. Preview the report. What items might you fix?

Remove the underline and apply bold formatting to the label, align the label with the
rest of the labels, increase the size of any cut-off fields, decrease decimal places, and so
on.

4. Format the new label to match the

appearance of the other labels.

a. In Design view, select the Quantity label.

b. In the Standard toolbar, click the Format

Painter .

c. Click the Running Total label.

d. Adjust the height of the label objects as

necessary so that no letters, such as the

letter g or y, are cut off at the bottom.

e. In the gray area at the left side of the
Page Header section, right-click, and

from the shortcut menu, select Select

All Section Objects.

f. Choose Format→Align→Bottoms.

g. Preview the report.

5. Which view mode should you use to remove the decimal digits from the running total

field, and why?

You should use Preview view, so that you can see the decimal digit values as you modify
their display. The decimal digits don’t appear in Design view.

6. Remove the decimal digits from the

Running Total field.

a. While previewing the report, click the

Running Total field for any record.

b. In the Formatting toolbar, click the

Decrease Decimals button twice.

c. Save the report.

You may want to review with
your students techniques for
modifying and formatting
labels and other objects.
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TOPIC B
Modify a Running Total Field
Once you insert a running total field into your report, you might find that it doesn’t provide
the results you wanted. In this topic, you’ll learn how to edit a running total.

Let’s say that your report contains a running total that calculates a sum and what you really
want is a count or an average. Rather than create a new running total field, you can edit the
existing field. You can also modify a running total field by changing the field that you are
summarizing.

Figure 1-4: You can modify a running total field at any time.

Ways to Modify a Running Total Field
There are four common modifications made to running total fields.

Change Description Example
Summary field Change the field being

summarized.
Find the average pay rate rather than the aver-
age number of hours worked.

Summary operation Change the type of sum-
mary operation being
performed.

Change a running total that currently sums
hours to show the average hours.

Running Total Field
Modification

Ways to Modify a Running
Total Field

LESSON 1

Crystal Reports 10.0: Level 28



FO
R 

EV
AL

UA
TI

O
N 

US
E 

O
NL

Y

DO
 N

O
T 

DU
PL

IC
AT

E

(C
) 2

00
4

El
em

en
t K

Co
nt

en
t L

LC

Change Description Example
Evaluation criteria Determine when the run-

ning total field should be
incremented. The default
setting is to increment the
running total on each
record. Other options
include calculating the
increment only when a
field changes, a group
changes, and/or an expres-
sion evaluates to true.

Increase the incremental running total only
when the customer region field is equal to CA.

Reset Determine the time when a
running total field should
be reset to zero. The
default setting is to not
perform a reset. Other
options include resetting
when a field changes, a
group changes, and/or
when an expression evalu-
ates to true formula.

In a report showing cumulative sales for the
last two years, reset the sales total to zero at
the beginning of each year.

How to Modify a Running Total Field
Procedure Reference:

To modify a running total field:

1. Display the Edit Running Total Field dialog box for the field you want to modify.

• In the Field Explorer, select the running total field, then click the Edit button.

• In the Field Explorer, right-click the running total field, and from the shortcut
menu, select Edit.

• On the Design or Preview tab, right-click the running total field, and from
the shortcut menu, select Edit Running Total.

2. If you want to modify the summary operation, then in the Summary section,
select the summary type you want from the drop-down list.

3. If you want to modify the field’s evaluation criteria based on a formula, then in
the Evaluate section, select Use A Formula. Click the Conditional Formula button
next to Use A Formula, and enter the evaluation formula in the Running Total
Condition Formula window.

4. If you want to set the reset option to change on group, then in the Reset section,
click On Change Of Group. Use the drop-down arrow to the right of the On
Change Of Group to select the group where the counter should be set back to
zero.

5. Click OK.

LESSON 1
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ACTIVITY 1-2
Modifying a Running Total Field

Setup:
The report RT-Saddle Sales.rpt is open.

Scenario:
You have been asked to separate the data in your report by calendar quarter, and to change the
running total so that it only displays Saturday sales. When you’re finished, your report should
look like Figure 1-5.

Figure 1-5: The report after it is grouped.
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What You Do How You Do It

1. Group the report by Calendar

Quarter.

a. Choose Insert→Group.

b. From the top drop-down list, box, select

Orders.Order Date.

c. From the bottom drop-down list box,
select For Each Quarter and click OK.

2. How would you identify Saturdays only?

You can use the DayOfWeek function, looking for those records where the DayOfWeek
function returns a 7.

3. What does it mean to set an evaluation on a running total?

By default, Crystal Reports will increment a running total for every record. When you set
an evaluation on a running total, you are asking that the increment only occur in a given
circumstance. For example, increment the total only if the order date is a Saturday. If
the order date is not a Saturday, do not add any value to the running total for that spe-
cific record.

4. What would the formula DayOfWeek ({Orders.OrderDate})=7 return if the order day

was a Saturday?

The True value.

5. What would the formula DayOfWeek ({Orders.OrderDate})=7 return if the order day

was a Wednesday?

The False value.

6. Edit the running total so that it only

sums Saturday Sales.

a. Right-click the running total field and

choose Edit Running Total.

LESSON 1
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b. Under the Evaluate section, select Use A

Formula and click the Conditional For-

mula button.

c. In the Functions tree, expand the Date

And Time category.

d. Expand the DayOfWeek category and

double-click DayOfWeek (date).

e. In the Fields tree, expand the xtreme

database category.

f. Expand the Orders table and double-

click Order Date.

g. Outside the last ) type =7

7. Check the formula for errors, and

then save and close.

a. Click Check .

b. At the No Errors Found message, click OK.

c. Click Save And Close .

8. Save the changes to the running

total field and change the Running

Total field label to Saturday Sales.

a. Click OK.

b. In the warning dialog box, click Yes.

c. Select the Running Total field label and

type Saturday Sales

d. Save the report.

e. If necessary, click Yes.
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9. Preview the report. How has the running total changed?

The running total only increases when there is a Saturday sale.

ACTIVITY 1-3
Suppressing the Running Total

Setup:
RT-Saddle Sales.rpt is open.

Scenario:
The report you’ve just created shows the proper information, but the running total column is
confusing your viewers. Since there are no Saturdays until the 7th record, blanks appear up to
that sale. Thereafter, the running totals are shown on every record, even when it’s not a
Saturday. You need to hide the running totals when the sale date is not a Saturday. When
you’re finished, your report should look like Figure 1-6.

Figure 1-6: The report showing only Saturday sales.
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What You Do How You Do It

1. Suppress the running total when it’s

not a Saturday.

a. Right-click the running total field.

b. Choose Format Field and select the

Common tab.

c. Click the Conditional Formula button

located to the right of the Suppress

option.

d. If necessary, in the Functions tree,
expand the Date And Time category.

e. From the DayOfWeek category, double-

click DayOfWeek (date).

f. In the Fields tree, double-click

Orders.Order Date.

g. Outside the last ) type <> 7

h. Check the formula, and then save and

close.

i. Click OK.

2. Preview the report. When does the running total appear?

Only when the order date is a Saturday.

Be sure your students right-
click the field on the layout,

and not within the Field
Explorer.
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ACTIVITY 1-4
Resetting the Running Total

Setup:
RT-Saddle Sales.rpt is open.

Scenario:
The report you’ve created counts all Saturday sales for the entire period reflected in the report.
You decide to calculate the Saturday sales within each calendar quarter starting over with a
zero at the start of each calendar quarter to help determine staffing needs on Saturdays. You
also want to show the running total for each quarter in the report to make the report easier to
read.

What You Do How You Do It

1. What section of the report represents a change in calendar quarter?

The Group Header 1 section.

2. Edit the running total so that it

resets on each calendar quarter.

a. Right-click the running total field, and

choose Edit Running Total.

b. Under the Reset section, select On

Change Of Group.

c. To the right of On Change Of Group,
verify that Group #1 is selected.

d. Click OK.

e. If necessary, click Yes.

3. Preview the report. How do you know that the reset is occurring?

The first Saturday in each calendar quarter contains the total for just that sale and is
then incremented up to the next calendar quarter.

4. How can you make the Saturday totals stand out for each calendar quarter?

Show the running total in the Calendar Quarter footer.
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5. Display the running total field in

the order date footer.

a. In Design view, right-click the running

total field and choose Copy.

b. Position the cursor in the Group Footer

#1 section, right-click and choose Paste.

c. Use the mouse to place the copied for-

mula in the Group Footer, so that it

appears beneath the Running Total field

in the Details section.

6. Preview the report. Did the field appear in every group footer?

No. The formula you copied is suppressed when the order date is not Saturday. You need
to remove the conditional formatting on your new copied formula.

7. Remove the conditional suppress

formula from the running total dis-

played in the calendar quarter

footer.

a. Right-click the running total field dis-

played in the calendar quarter footer

and choose Format Field.

b. On the Common tab, click the Condi-

tional Formula button located to the

right of the Suppress option.

c. Delete the formula.

d. Save and close the Format Formula

Editor.

e. Click OK.

8. Preview the report. Where do the totals appear now?

In the Details section when the order date is a Saturday, and in the group footer section
for all groups.

9. Save and close the report. a. Save the report.

b. Close the report.
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TOPIC C
Create a Manual Running Total on
Detail Data
As you begin to create more complex reports, you’ll use Crystal Reports’ manual running total
to insert and edit running totals in your report. There might be times when you need to create
your own running total because Crystal Reports’ is either not available and/or not reliable. In
this topic, you’ll create sequential summing on a field.

In many simple reports, Crystal Reports’ built-in running total feature works fine. However,
running totals can be problematic in more complex reports. Reports with more than 10 group
levels and/or reports with suppressed sections can cause a running total to be incorrect. Com-
mon practice is to create manual running totals rather than rely on the built-in Crystal Reports
feature. It requires more work, but is a dependable solution for your running total needs.
Understanding how manual running totals work is essential, especially when you need to
report running totals in summary sections.

Variable Declaration
Definition:

A variable is a value that can change, which is used as part of a formula. Before you
can use a variable in a formula, it must be “declared” or introduced in the formula by
providing a name and a type. This is done by using a variable declaration followed by
the name of the variable. For example, a variable declaration for a numeric variable is
NumberVar MyNumber. An example of a variable declaration for a numeric variable
that also assigns a value to the variable is NumberVar MyNumber := 0;.

Example:

Figure 1-7: You can specify a formula value as a variable to indicate that the
value can change.

Variable Declaration Keywords
The following table displays a list of the common variable declaration keywords used in Crys-
tal Reports formulas.

Data Type Variable Declaration
Number NumberVar

If the concept of variables is
new to students, have them go
to the Crystal Help screen and
type variables on the index
tab.

Common Variable Declaration
Keywords
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Data Type Variable Declaration
String StringVar

Date DateVar

Date/time DateTimeVar

Currency CurrencyVar

How to Create a Manual Running Total on Detail
Data
Procedure Reference:

To create a manual running total on detail data:

Formulas can also be created directly in the Formula Workshop window. For example, selecting the
Group Selection icon under Selection formulas will open the Group Selection Formula Editor. Condi-
tional formulas can even be added by right-clicking the report object from the Formatting Formula
category and choosing New Formatting Formula from the shortcut menu.

1. In the Field Explorer, select Formula Fields.

2. Click the New button, type a name for the running total field, and click Use
Editor.

3. Type (or select) WhilePrintingRecords as the first line for the formula. If you
want to select the function, rather than type it, then expand the Evaluation Time
function category and double-click WhilePrintingRecords. Evaluation formulas
must always be the first line in a formula because they determine when the for-
mula will be processed.

4. Type a semicolon (;) and press Enter to move to a new line.

5. Declare the variable and variable type, such as NumberVar RunTotal. Doing this
sets aside a place in the computer’s memory, called an address, in which to store
the variable contents. The variable type is used to determine how much space is
needed; the name is used to reference the variable in the current formula and in
other formulas when applicable. If a variable type and name are not specified, the
variable does not exist and cannot be used in a formula.

6. Complete the formula to set the running total field calculations. In most cases, the
variable name will be added to the field name, for example, NumberVar RunTotal
:= RunTotal + {table.field name}

7. Drag the formula into the Details section.
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ACTIVITY 1-5
Creating a Manual Running Total on Detail Data

Data Files:

• Manual RT-Saddle Sales.rpt

Setup:
No files are open.

Scenario:
You’re troubleshooting a report that you’ve inherited that contains a running total field, and
you aren’t sure if it’s running properly. You want to create a manual running total to compare
the results. When you’re finished, your report should look like the following figure, Figure 1-8.

Figure 1-8: Comparing a manual versus a running total.

What You Do How You Do It

1. In Manual RT-Saddle Sales.rpt, which field do you want to increment by its previous

value?

Orders_Detail.Quantity.
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2. How would you write a formula that will increment the Quantity field, adding itself to

the previous quantity, creating a running total?

Create a variable to hold the temporary contents, and add the Quantity field to the vari-
able while the records are printing.

3. In the Manual RT-Saddle Sales.rpt
report, create a formula called

ManualRT that will display a run-

ning total of sales volume. Place the

formula to the right of the built-in

Crystal Reports running total

formula.

a. In the Field Explorer, select Formula

Fields and click the New button.

b. In the Formula Name dialog box, type

ManualRT and click Use Editor.

c. Place the insertion point in the formula

window and type WhilePrintingRecords;
and press Enter.

d. In the Operators tree, expand the Vari-

able Declarations category.

e. Double-click NumberVar x := y;

f. Type RunTotal and delete the colon and

equal sign, leaving the semicolon. Be

sure there are no spaces between

RunTotal and the semicolon.

g. Press End and then press Enter.

h. Type RunTotal :=RunTotal

i. In the Operators tree, expand Arithmetic

and double-click Add (x + y).

Hint: The first category in the list.

You may want to point out to
your students that they could

also insert the
WhilePrintingRecords function

by expanding the Evaluation
Time function category and

double-clicking
WhilePrintingRecords.
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j. In the Fields tree, double-click Orders_

Detail.Quantity.

4. Check the formula for errors, and

then save and close the formula

editor.

a. Check the formula for errors and click

OK.

b. Save and close.

5. Insert the ManualRT formula into

the report and preview the report.

a. Drag the ManualRT formula to the

Details section to the right of Saddle RT.

b. Preview the report.

c. Format the new field’s label to match

the other field labels, and to align to

them.

d. Remove the decimal digits from the field

itself.

6. What calculation is your new formula performing?

The manual running total displays the same answers as the built-in Crystal Reports run-
ning total, in each case incrementing itself by the current field quantity.

Save and close the report.

Multi-pass Reporting
As Crystal Reports pulls together data for presentation on a report it may need to make
several “passes” through the data. Crystal Reports refers to this as “multi-pass
reporting.” The following table identifies the report processing order:

Name
What is processed and in what
order? Examples

Pre-Pass #1 Constant Formulas (not depen-
dent upon database data).

30*234
DateAdd(“d”,10,PrintDate)

You may want to remind your
students to use the Format
Painter to quickly format the
new field label.

Report Processing Order
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Name
What is processed and in what
order? Examples

Pass #1 1. Record Selecting and Sorting
from the server.

Pull 6 fields from the sales table where field
x=y

2. Formulas that don’t include
summary information (this for-
mula type is called a Recurring
Formula).

{table1.fielda}*30
{table1.fieldb}*{table1.fieldc}

3. Record Selecting and Sorting
that could not be done at the
server level.

Data that is grouped by “specified grouping
order.” Filters that do not appear in the
where clause of the underlying SQL query.

4. Sorting, grouping, and totaling. Sum({orders.order quantity})

5. Cross-tab generation Creation of any cross-tab object.

6. Saving of data (this is the last
pass that requires record retrieval
from the database)

N/A

Pre-Pass #2 Top/Bottom N and Hierarchical
Grouping

Top N formula to return the Top 10 custom-
ers — i.e. Top 10 of Sum ({Orders.
OrderQuantity},{Customers.CustomerID})

Pass #2 1. Group Selection Formulas Limit report based on the contents of a sum-
mary field in a group footer i.e.
Sum({Orders.OrderQuantity},{Customers.
CustomerID})>5000

2. Running Totals Running totals that have been built using the
Insert Running Total feature.

3. Calculations specifically
marked “While Printing Records”

Any formula where the first line
is“WhilePrintingRecords;” (This includes
manual running totals)

4. Charts, maps n/a

5. Subreports n/a

Pass #3 Total Page Count Page N of M (Insert, Special Field)

These “passes” through the data can also be related to Evaluation Time functions set
by the user. Assigning an Evaluation Time function to a formula forces the calculation
of the data to occur in the corresponding pass shown in the following table.

Evaluation Time Function Pass Sample Use
BeforeReadingRecords Pre-Pass #1 A variable might be used to capture the

system time on start of a report. Speci-
fying BeforeReadingRecords will ensure
that it doesn’t get calculated after the
records have been retrieved.

Evaluating Time Function
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Evaluation Time Function Pass Sample Use
WhileReadingRecords Pass #1–initial read This is often used as a troubleshooting

tool to determine when records are
evaluated. The formula checker will
return an error if an expression or other
part of your formula needs to be evalu-
ated later.

WhilePrintingRecords Pass #2 (after Group
Selection formulas and
built in running totals)

Manual running total formulas.

EvaluateAfter(x) N/A-calculation is done
after “x”, where x is
the name of another
formula in the report.

When you have two formulas that will
be printed in the same evaluation time
but need control over which one gets
calculated first because the results of
the first formula are needed for the sec-
ond formula.

DISCOVERY ACTIVITY 1-6
Troubleshooting a Report

Data Files:

• Helmet Sales by Color.rpt

Setup:
No files are open.

Scenario:
Your co-worker created a manual running total but states it is not working properly. You need
to troubleshoot the report and correct any errors.

1. Open Helmet Sales by Color.rpt and explore the report formulas using the Formula

Workshop.

2. Which of these formulas involves the running total calculations?

Only the RTBlack and RTWhite formula fields.

3. How could you change the evaluation time of this formula, forcing it to calculate after

the record sort?

Add WhilePrintingRecords to the first line of the formula.

4. Modify the formula RTWhite to insert WhilePrintingRecords;.
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5. Make the same fix for the RTBlack formula.

6. Does this solve the problem?

Yes.

Save and close the report.

TOPIC D
Create a Manual Running Total on
Summary Data
Sometimes, you don’t need to see all the detail in a report and you only want a summary. In
this topic, you’ll create a manual total on summary data but you still need a running total on
summary data.

It’s not uncommon to want running totals of subtotals, and manual running totals are the most
dependable way to do this. Let’s say you have a report that shows total sales by employee per
month, and you now want to see the running total over the year for the same employee. The
monthly total may be a simple sum operation; the running total showing the yearly sales accu-
mulation will be a running total on the summary field.

How to Create a Manual Running Total on
Summary Data
Procedure Reference:

To create a manual running total on summary data:

1. In the Field Explorer, select Formula Fields.

2. Click the New button, type a name for the running total field, and click Use
Editor.

3. Type (or select) WhilePrintingRecords as the first line for the formula.

4. Type ; and press Enter to move to a new line.

5. Declare the variable and variable type, such as NumberVar RunTotal.

6. Complete the formula to set the running total field calculations. In most cases, the
variable name will be added to the field name, such as NumberVar RunTotal :=
RunTotal + {table.field name}.

7. Drag the formula into the Group section where you want it to appear in the
report.
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ACTIVITY 1-7
Creating a Manual Running Total on Summary Data

Data Files:

• Saddle Sales by Month.rpt

Setup:
No files are open.

Scenario:
You have a report called Saddle Sales by Month.rpt that is grouped by month, displaying a
quantity total for each month. You want to show a running total of the month sales, with
cumulative totals starting over in a new calendar year. Figure 1-9 shows the completed report.
In this case, the Crystal Reports running total formula is not available.

Figure 1-9: This report’s running totals have been created manually.

What You Do How You Do It

1. In Saddle Sales by Month.rpt, what formula would you use to increment the month

totals?

Store the (cumulative) previous month totals in a number variable. Add the current
month total to the variable with each record.
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2. Insert a manual running total for-

mula named ManualRT for the

month quantity field.

a. In Saddle Sales by Month.rpt, if necessary,
display the Field Explorer.

b. Select Formula Fields and click the New

button.

c. Type ManualRT and click Use Editor.

d. In the Functions tree, if necessary,
expand the Evaluation Time category

and double-click WhilePrintingRecords.

e. Type ; and press Enter.

f. In the Operators tree, if necessary,
expand the Variable Declarations cat-

egory and double-click NumberVar x

:=y;.

g. Type SumTotal and delete the extra

characters except the semicolon.

h. On a new line, type SumTotal
:=SumTotal +

i. In the Fields tree, expand Report Fields

and double-click the summary field for

Group#1 that sums the quantity.

3. Check the formula, and then save

and close.

a. Check the formula and click OK.

b. Save and close.

4. In the Page Header, add Running
Total as a text object label at the

2.5-inch mark.

a. In the Page Header, create a text object

called Running Total

b. Place the text object approximately at

the 2.5-inch mark.

c. Modify the new text object to match the

formatting and alignment of the existing

items in the Page Header.

You may want to remind your
students that they can use the

Format Painter to quickly copy
the formatting from one of the

other text objects to the new
text object.
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5. Insert the formula into the group

header below the Running Total

text label, decrease the decimal

places, and preview the report.

a. Drag the ManualRT formula from the

Field Explorer into the Group Header to

the right of Quantity, at the 2.5-inch

mark.

b. Preview the report.

c. Decrease the decimal places.

6. Insert a group using the Order Date

field and sort in ascending order

grouped by year.

a. On the Insert Group dialog box, from the
top drop-down list, select Orders.Order

Date.

b. From the bottom drop-down list, select

For Each Year.

c. Click OK.

7. Swap group 1’s position with group

2’s so that the first grouping is by

Year and the second grouping is by

Month, and preview the report.

a. In Design view, in the gray area, drag the

Group Header #2 up into Group Header

#1.

b. Preview the report.

8. What number does the 2001 running total start with?

14.

9. What do you need to do with the running total to correct this problem?

Make our variable equal to zero at the start of each new year (Group #1). The formula
would be:

WhilePrintingRecords;
NumberVar SumTotal :=0
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10. Create a reset formula called Reset
to reset the running totals for each

year.

a. In the Field Explorer, select Formula

Fields and click New.

b. Type Reset and click Use Editor.

c. In the Functions tree, expand the Evalua-

tion Time (if necessary) and double-click

WhilePrintingRecords.

d. Type ; and press Enter.

e. Type NumberVar SumTotal :=0

11. Check the formula, and then save

and close.

a. Check the formula and click OK.

b. Save and close.

12. Where should you position the formula so that the running total will be a zero at the

start of each calendar year?

In Group Header #1.

13. Position the Reset formula in the

Year group header and suppress it.

a. Drag the Reset formula from the Field

Explorer to the GH#1, below the Run-

ning Total field label.

b. Right-click the Reset formula and choose

Format Field.

c. Select the Common tab and check the

Suppress check box.

d. Click OK.
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14. In the Group Footer #1, create a for-

mula called ShowR to show the

running total for each year.

a. In the Field Explorer, select Formula

Fields and click New.

b. Type ShowR and click Use Editor.

c. In the Functions tree, in the Evaluation
Time category, double-click

WhilePrintingRecords.

d. Type ; and press Enter.

e. Type NumberVar SumTotal :=SumTotal;

f. Check the formula, and save and close.

15. In the Group Footer, create a text

object called Annual Total and drag

the ShowR formula into the footer.

a. In the Group Footer, create a text object

called Annual Total:

b. Drag the ShowR formula into the footer

next to the Annual Total text object.

c. Preview the report.
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16. Format the fields and labels as

desired.

a. In Design view, drag the bottom of the

Group Footer #1 section down to add

space between each group.

b. Move the Group Footer #1 section con-

tents down slightly.

c. Using the Insert Box tool, draw a box

around the two items in the Group

Footer #1 section.

d. With the box selected, choose Format→
Format Box.

e. On the Box tab, check the Color check

box.

f. From the Color drop-down list, select the

yellow color, then click OK.

g. Right-click in the gray area at the left

side of the Group Footer #1 section, and

choose Select All Section Objects.

h. Use the Right Arrow key to move the

items to the right, then preview the

report.

i. Save and close the report.
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Lesson 1 Follow-up
You now know how to use running totals in a report to provide cumulative incremental totals
in your reports. Continuous running totals can be helpful in many situations, including inven-
tory control, sales tracking, and budgeting cash flow.

1. Do you think you’ll use running totals in your reports? Why or Why Not?

Answers will vary.

2. What do you think are some advantages to using running totals? Disadvantages?

Answers will vary.
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Building Cross-tabs in Your
Report

Lesson Objectives:
In this lesson, you will build cross-tabs in your report.

You will:

• Create a cross-tab.

• Create a specified group order in a cross-tab.

• Filter a cross-tab by group.

• Change the format of the cross-tab.

• Conditionally format rows and columns in a cross-tab.

• Keep groups together.

Lesson Time
1 hour(s), 15 minutes to
1 hour(s), 45 minutes

LESSON 2
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Introduction
You know how to use running totals to analyze and summarize data in your reports. A cross-
tab is another tool you can use to perform a calculation on a summarized field in your reports
to generate totals and grand totals. In this lesson, you’ll use cross-tabs to perform calculations
on report summary data.

You’ve probably seen a grouped report made up of many rows and columns of data. As you
know, the content can be spread out over several pages making it difficult to analyze the data.
A better alternative would be a cross-tab. Cross-tabs are helpful because the data is presented
in a compact object made up of rows and columns that make it easy to compare data and iden-
tify trends. Figure 2-1 shows you the comparison between a list report and a cross-tab report.

Figure 2-1: A list report versus a cross-tab report.

List Report versus Cross-tab
Report
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TOPIC A
Create a Cross-tab
You’ve already worked with grouped reports and long lists of data. A great way to consolidate
summary data is by displaying it in a grid format. In this topic, you’ll create a cross-tab object
in your report.

Cross-tabs are useful when large amounts of summary data needs to be presented clearly in a
limited space. Suppose you had a report that displayed last year’s sales grouped by salesper-
son, and secondarily grouped by customer. You might spend a lot of time creating and
formatting this report to display the data as clearly as possible. However, you could most
likely create a cross-tab report for the data more quickly. In addition, a cross-tab would typi-
cally display the data in a smaller space, and in a format more easily analyzed by viewers.

Figure 2-2: You can use a cross-tab to quickly display complex data in a structured
format.
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Planning a Cross-tab
Before you create a cross-tab it’s a good idea to have a plan for the structure. Use the follow-
ing list of items to identify the components you will need to produce a cross-tab.

• What field(s) or formulas will represent your row headings?

• What field(s) or formulas will represent your column headings?

• Do grouping options need to be set for the row or column headings, and if so, is the data
in a format that will lend itself to this grouping easily?

• What data do you need to summarize?

• What summary operation (sum, average, count) do you need for the summary fields?

DISCOVERY ACTIVITY 2-1
Planning a Cross-tab

Scenario:
You need to create a report on bicycle sales that shows total sales by product type and name
and you want all of the information on one page. Based on this information, you need to plan
a cross-tab. Figure 2-3 shows the tables you will be reporting on. Your cross-tab will look like
Figure 2-4.

Figure 2-3: Tables needed for the cross-tab.
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Figure 2-4: The completed cross-tab.

1. What table and field contains the product type?

The field can be found in two places.

Table Field
Product Product Type ID

Product_Type Product Type ID

2. Does it matter which field you use for your column heading?

The output will look the same with either field, but performance may vary. If perfor-
mance is an issue, testing should be done to see which yields faster results. Indexed fields
and number of records will impact performance.

3. What table and field represents the Product Type name?

Product_Type table, Product Type Name field.

4. Could you use that field for your column heading?

Yes. However, that field is not indexed. Using indexed fields for column and row head-
ings, when possible, provides the best performance.

5. What table and field contains the bicycle names?

Product table, Product Name field.
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6. When selecting the column heading, a decision was made to use the indexed ID field to

increase performance. In this example, could you use the Product ID field instead of

the Product Name?

No. Even though using the product ID would result in better performance, some product
IDs have the same product names. This would result in duplicate product name rows.

7. What table and field contains the information you want summarized?

Orders_Detail table, quantity field.

8. What summary operation will you perform?

Summing the quantity field.

Cross-tab
Definition:

A cross-tab is a report presented in a column and row format that summarizes and pre-
sents data making it easy to identify trends and compare data. Rows in a cross-tab run
horizontally. Columns in a cross-tab run vertically.

Example:

Figure 2-5: This cross-tab displays sales totals generated by each salesperson
from each customer.

Summarized Field
Definition:

A summarized field is a field that represents a summary such as a sum, count, or aver-
age of multiple values. In a cross-tab, summarized fields are found at the intersection
of a row and a column.

Example:
The following list report and cross-tab both show summarized fields. Each value
shown is the sum of all sales to a given customer by a given salesperson.

Summary Fields
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Figure 2-6: Summary data can appear in a list report or in a cross-tab.

How to Create a Cross-tab
Procedure Reference:

To create a cross-tab:

1. Choose Insert→Cross-Tab to open the Cross-Tab Expert dialog box.

2. In the Available Fields list box, select a field for the column and click the arrow
next to the Columns box.

3. In the Available Fields list box, select a field for the row and click the arrow next
to the Rows box.

4. In the Available Fields list box, select the field to be summarized and click the
arrow next to the Summarized Fields box.

5. The default summary is Sum. If you want to select a different operation, click the
Change Summary button.

6. If necessary, apply any additional structure such as Group Options or Formulas.

7. If necessary, apply a style.

8. Click OK to close the Cross-Tab Expert dialog box and create the cross-tab.
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ACTIVITY 2-2
Creating a Cross-tab

Data Files:

• 2001-02 Bike Sales.rpt

Scenario:
You have your cross-tab planned. You know that the Product Name is the row, Product Type
ID is the column, and Orders_Detail.Quantity is the summarized field. Given this information
and the steps you used to plan the cross-tab, you are now ready to create the cross-tab.

What You Do How You Do It

1. In 2001-02 Bike Sales.rpt, on the
Design tab, create a cross-tab that

shows the total quantity of bicycles

sold, grouped by Product Name

(row) and Product Type ID

(column).

a. In 2001-02 Bike Sales.rpt, on the Design
tab, choose Insert→Cross-Tab.

b. In the Available Fields section, select

Product.Product Type ID and click the

arrow next to the Columns area.

c. With the Product.Product Type ID field
highlighted, click Group Options, and on

the Options tab, check the Customize

Group Name Field check box.
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d. In the Choose From Existing Field drop-
down list, select Product_Type.Product

Type Name and click OK.

e. In the Available Fields section, under
Product, select Product Name and click

the arrow next to the Rows area.

f. In the Available Fields section, under
Orders_Detail, select Quantity and click

the arrow next to the Summarized

Fields box.

g. Click OK.

2. Place the cross-tab in Report

Header B and save the report as

2001-02 Bike Sales.rpt.

a. The mouse pointer is holding a box to rep-
resent the cross-tab. Place the mouse

pointer in Report Header B next to the

subtitle Bicycles and click.

b. Save the report.

3. Preview the cross-tab. Does this match the planned cross-tab?

Yes.
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4. What order did the groups sort?

Product names sorted alphabetically. Product types sorted by the ID field used in the
grouping. By default, Crystal Reports will sort cross-tab data alphabetically by the field
used for grouping.

TOPIC B
Create a Specified Group Order
Besides specifying the field that you want to use for the row and column, you can change the
order of the grouped data. Crystal Reports enables you to control the sort order and group
options in cross-tabs. You might want it ordered or grouped differently than the default. In this
topic, you’ll specify your own group order in a cross-tab.

When you create a cross-tab, groups default to an alphabetical/numerical sort order. There will
be times when you need to override the alphabetical sort to present data non-alphabetically.
For example, if row headings represent countries you do business in, you might be requested
to put the USA in the first entry, regardless of alphabetical order. Another feature of the speci-
fied group order is that it enables you to create your own groups from existing data without
the need for the group field to be in the database. An example of this would be combining all
US sales into a single category, and all international sales into another category.

Figure 2-7: You can specify the group order for cross-tabs.

A Specified Group Order
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Specified Group Order
When you are grouping data, specified order is an order that is determined by you, the user.
The Cross-Tab Group Options dialog box contains the specified order option to enable you to
create the customized groups that will appear on the cross-tab and the records that each group
will contain.

How to Create a Specified Group Order in a
Cross-tab
Procedure Reference:

To create a specified group order in a cross-tab:

1. On the Cross-Tab Expert dialog box, select the row or column field by which
your cross-tab will be grouped.

2. Select Group Options to display the Cross-Tab Group Options dialog box.

3. Select In Specified Order as your sort option to display the Cross-Tab Group
Options dialog box.

4. Enter a name for the group and click New.

5. Select a comparison operator and then enter the product names in the group.

6. Click OK to close the Define Named Group dialog box.

7. Click OK to close the Cross-Tab Group Options dialog box.

8. Click OK to close the Cross-Tab Expert dialog box.

The ability to sort data in specified order is not limited to cross-tabs. Specified group order can
be applied to report groups using the Change Group Option menu from the shortcut menu.
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ACTIVITY 2-3
Creating a Specified Group Order

Setup:
2001-02 Bike Sales.rpt is open.

Scenario:
Currently the row grouping is by Product Name. Let’s say that you want all the Nicros to be
in one group (Micro, Mini, and ordinary Nicros should all be shown under Nicros). They don’t
need to be separated because they are all the same product. All others should remain in their
own groups.

What You Do How You Do It

1. How many Nicros products are there?

Three. Nicros, Micro Nicros, and Mini Nicros.

2. Display all the Nicros products in

one group that includes Nicros, Mini
Nicros, and Micro Nicros.

a. If necessary, select the cross-tab object

and choose Format→Cross-Tab Expert.

b. In the Rows box, select Product.Product

Name and click Group Options.

c. From the bottom drop-down list, choose

In Specified Order.
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d. In the Named Group box, type Nicros and

click New.

e. Set the Product Name comparison

operator to Is One Of.

f. Type Nicros and press Enter (or click

Add).

g. Type Mini Nicros and press Enter.

h. Type Micro Nicros and press Enter.

i. Click OK.

j. On the Others tab, select Leave In Their

Own Groups and click OK.

k. Click OK.
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3. Preview the report. How many times does the Nicros group appear?

Once.

Save the report.

TOPIC C
Filter a Cross-tab by Group
So far you have created the cross-tab and changed the grouping of data in a cross-tab. But
what if you want to see the same cross-tab information as it relates to other groups in your
report? Do you have to start from scratch and create an entirely new cross-tab? In this topic,
you’ll filter a cross-tab by group.

Cross-tabs display summary data by group. Putting a cross-tab in a report group will further
filter the summary data by the group field. For example, let’s say you have created a cross-tab
showing last year’s sales by employee. The information is presented at the beginning of your
report and covers all countries. Your report also shows data that is grouped by country. You
can display the employee sales cross-tab, formatted the same as at the beginning of the report
but with a separate cross-tab appearing for each country.

A Cross-tab Filtered by Group
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Figure 2-8: You can copy a cross-tab into a report group to display data from only
that group.

How to Filter a Cross-tab by Group
Procedure Reference:

To filter a cross-tab by group:

1. Determine which group you want to view the cross-tab data in. If the group does
not exist, create the group using the Insert Group dialog box.

2. Select the field you want to group by and the group options and click OK.

3. Drag the cross-tab from the report header into the desired group header or footer.
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ACTIVITY 2-4
Filtering a Cross-tab by Group

Data Files:

• 2001-02 Bike Sales.rpt

Setup:
The 2001-02 Bike Sales.rpt file is open.

Scenario:
You want to see how many bikes were sold in 2001 versus 2002. You don’t want all the data
mushed together so you decide to create one cross-tab for 2001 another one for 2002.

What You Do How You Do It

1. Group the 2001-02 Bike Sales.rpt

by Calendar Year using the Order

Date field.

a. In 2001-02 Bike Sales.rpt, display the

Insert Group dialog box.

b. From the top drop-down list, choose

Orders.Order Date.

c. From the bottom drop-down list, choose

For Each Year.

d. Click OK.

2. Format the group header so that

the entire year appears and expand

the group header section so the

cross-tab will fit under the group

name.

a. Right-click the Group #1 Name field and

choose Format Field. On the Date And
Time tab, select 03/01/1999 and click

OK.

Make sure the date options are
set before you attempt this

step.
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b. In Design view, increase the size of the

Group 1 header section.

3. Drag the cross-tab from the report

header into the GH1 section and

preview the report.

a. Select the cross-tab object and drag it

down to the Group Header #1 section.

b. Preview the report.

c. Because you’re grouping by Year, you only
see the Year data. Save the report.

The cross-tab could also be copied from the
report header to the group header which would
result in one cross-tab summarizing all data,
and then a separate cross-tab for each group.
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TOPIC D
Change the Cross-tab Format
You have your cross-tab created, sorted, and filtered. But what if you don’t like the way the
cross-tab looks? You don’t have to accept the default format of the cross-tab, you can modify
its appearance to meet your needs. In this topic, you’ll change the cross-tab format by modify-
ing fonts, borders, and colors.

Not only do cross-tabs enable you to change the type of data that you want to present, you can
also modify its appearance. For example, you can change colors so that the cross-tab not only
looks better in the report, you can use colors and borders to highlight specific information in
the cross-tab to draw attention to particular trends.

Figure 2-9: You can apply a style to format a cross-tab.

Formatting Options
The following table lists common cross-tab formatting options found on the Customize Style
tab, in the Cross-Tab Expert dialog box.

Item Description
Show cell margins This option adds white space between the text and the cell

borders. Unchecking this option decreases the size of a cross-tab.

Indent row Labels Set the amount of second line indentation (inch scale) in the row
headings.

Repeat Row Labels Use this whenever a cross-tab does not fit on one page to include
the row heading on each page.

Customized Cross-tab
Formatting

Cross-tab Formatting Options
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Item Description
Keep Columns Together Use this whenever a cross-tab does not fit on one page to avoid

page breaking within a column.

Column Totals On Top / Row
Totals On Left

Some cross-tab styles position column totals on the bottom and/or
row totals on the right. Use these options whenever you desire to
change the placement of totals.

Suppress Empty Rows / Suppress
Empty Columns

Some rows or columns may contain fields with no data, in which
case you can specify that those rows or columns be hidden.

Suppress Row Grand Totals / Sup-
press Column Grand Totals

Row and/or Column totals can be hidden from view when desired.
This is particularly useful when your cross-tab does not contain
both row and column headings.

Format Grid Lines Control the color, size, and suppression of grid lines. Useful to set
row and column headings apart from summary data and/or to bet-
ter separate multiple column/row headings.

How to Change the Cross-tab Format
Procedure Reference: Format a Cross-tab

To change the format of a cross-tab:

1. Open the Cross-Tab Expert dialog box for the cross-tab you want to format.

• Select the cross-tab that you want to edit, then choose Format→Cross-Tab
Expert. You must be sure to select the entire cross-tab, and not only a single
field within it. To select the entire cross-tab, click a blank area of the cross-
tab, or drag a selection marquee around the entire cross-tab.

• Right-click a blank part of the cross-tab, and choose Cross-Tab Expert.
Right-clicking on a specific field or label will cause the shortcut menu to
display commands for formatting that one item, rather than the Cross-Tab
Expert command.

2. Make changes to the cross-tab object in the Cross-Tab Expert dialog box using
the Style or Customize Style tab.

3. Click OK to close the Cross-Tab Expert dialog box.

4. If you want to modify the font or background colors for particular cross-tab cells,
then select the desired cell, and specify options using the Formatting toolbar.

The data displayed in a cross-tab can also be formatted directly in the cross-tab using the appli-
cable format options. For example, row height can be increased using the sizing arrows, font
sizes could be changed using the formatting toolbar, and so on.

Procedure Reference: Adjust Cross-tab Column and Row Sizes

To adjust a cross-tab column width or row height:

1. If you want to resize the columns and rows based on their contents, then click the
Preview tab so the cross-tab data is visible.

2. Click a field in the column or row you want to adjust.

3. Drag the field’s handles to adjust the row or height size.
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4. If you want to specify column width and row height amounts numerically, then
right-click any row or column and choose Size And Position. Specify a row
height or column width, then click OK.

ACTIVITY 2-5
Changing the Cross-tab Format

Setup:
The report 2001-02 Bike Sales.rpt is open.

Scenario:
You want to make the 2001-02 Bike Sales.rpt cross-tab smaller so that it will fit as an insert in
your annual sales report. Additionally, the audience only needs to see the total sales per prod-
uct type rather than by bicycle name.

What You Do How You Do It

1. Format the cross-tab so that the

grand total row is suppressed and

the cross-tab is smaller.

a. In Design view, right-click the cross-tab’s

blank area at the top left, and choose

Cross-Tab Expert.

b. Select the Customize Style tab.

c. Uncheck Show Cell Margins.

d. Check Suppress Row Grand Totals.

e. Click OK.

2. Does the cross-tab take up less space than it did before?

Yes.

3. Do the row grand totals appear?

No. They are hidden.

4. Do the column and row headings stand out from the summary data?

No. They blend together.

5. How can you correct this?

Answers will vary, but one possibility is to make the gridlines bolder between the sum-
mary data and the headings.
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6. Make the following gridlines wider:

row labels right border and column

labels bottom border.

a. In the Cross-Tab Expert dialog box, on the
Customize Style tab, under Grid Options,
click Format Grid Lines.

b. Select Row Labels Right Border and

change the Width to 1 pt.

c. Select Column Label Bottom Border and

change the Width to 1 pt.

d. Click OK.

e. Click OK.

7. The headings are now better separated from the summary data, but is the cross-tab

easier to read?

No. When the overall size of the cross-tab was made smaller, it made it difficult to read.
It would be easier to read if you made the rows larger, still keeping it smaller than the
original cross-tab.

8. Slightly increase the height of all

rows.

a. On the Preview tab, click any row.

b. Drag the top or bottom selection handle

to increase the row height slightly.

c. Adjust the height of any other rows as

necessary.

d. Adjust the width of any columns as nec-

essary so that all the field contents are

fully displayed.

e. Save and close the report.
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TOPIC E
Conditionally Format Rows and
Columns
Now that the structure of the cross-tab is set, you might find that you need to emphasize cer-
tain parts of the cross-tab by applying formatting based on criteria you specify. In this topic,
you will change the format for data that meets specified criteria within rows and columns.

A cross-tab is a moving target in that the contents of the row, column headings, and summary
data are not known ahead of time. Fortunately, you can still format data based on the data val-
ues within this moving target. For example, you might want to highlight all regional sales that
exceed a monthly target total, or use a different color font to identify different product types.

Figure 2-10: Conditional formatting automatically formats values that meet specified
criteria.

Cross-tab Row and Column Headings in Formulas
Fields used for cross-tab rows and column headings cannot be used directly in a formula. The
user must first assign a name to the field that is used for the row or column headings. This
name is called an alias, and is set on the Cross-Tab Expert dialog box on the Customize Style
tab. Formulas can then be created using the alias name rather than the field name.

How to Conditionally Format Rows and Columns
Procedure Reference:

To conditionally format rows and columns:

1. Open the Format Field dialog box for the cross-tab field you want to format.

• Select the field, then choose Format→Format Field.

• Right-click the field, then select Format Field.

2. Activate the tab that contains the option you want to change.

• On the Common tab, select the Conditional Formula button to modify sup-
press options and horizontal alignment.

A Cross-tab with Conditionally
Formatted Rows and Columns
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• On the Border tab, select the Conditional Formula button to modify line
style, drop shadow, border, and background colors.

• On the Font tab, select the Conditional Formula button to modify font, style,
size, color, and effects such as strikeout and underline.

3. Enter the formula to apply the Conditional Formula.

4. Check the formula and then save and close the format Formula Editor window.

5. Click OK to close the Format Editor dialog box.

DefaultAttribute
DefaultAttribute is a constant used by Crystal Basic formula syntax. You have seen the
use of other constants such as crRed, crPurple, and crDoubleLine. These constants
define a type of formatting, whether it is for color, border styles, font types, or any
other type of formatting. Using the DefaultAttibute constant in a formula causes the
format selection chosen by the user to appear whenever the conditional condition is not
met.

For example, let’s say the DefaultAttribute for the font color is teal. That is the color
that was selected by the user. Conditional formatting can be applied to this same font
color to cause the teal to be a different color if a particular condition is met. Using the
DefaultAttribute in the else statement of a conditional formula in this example would
cause the font color to be teal if the condition was not met. Not using the else state-
ment with the DefaultAttribute constant would cause the color to be “automatic”
(typically black) even when the condition was not met.

Special Cross-tab Functions
The following table identifies the functions you can use to apply conditional formatting
on fields in a cross-tab.

Function Name When Would You Use It Example(s)
CurrentFieldValue To conditionally format a

cross-tab summary field based
on the numerical value of the
summary field.

Apply red font color on all sum-
mary fields exceeding $500.
Formula: If
CurrentFieldValue>500 then
crRed else DefaultAttribute
Applied on: conditional format
font color of summary field

CurrentFieldValue To conditionally format a
cross-tab row or column head-
ing based on the value of the
row or column heading

Apply red font color on the Row
heading named “Romeo”. All
other row headings retain the
default color setting.
Formula: If CurrentFieldValue =
“Romeo” then crRed else
DefaultAttribute.
Applied on: conditional format
font color of row heading field.

Special Cross-tab Functions
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Function Name When Would You Use It Example(s)
IfGridRowColumnValue To conditionally format a

cross-tab summary field based
on the value of the row or
column heading.

Apply red font color to all sum-
mary fields where the row
heading is named “Romeo”.
Formula:
IfGridRowColumnValue
(“Pname”) = “Romeo” then
crRed else DefaultAttribute.
Applied on: conditional format
font color or summary field.

The function CurrentFieldValue can be typed or selected from the formatting functions category of the
function menu. This function only appears when you are in a cross-tab object.

ACTIVITY 2-6
Conditionally Formatting Rows and Columns

Data Files:

• Bike Sales Detail 00-01.rpt

Setup:
No files are open.

Scenario:
You receive a discount from your supplier for any products where the sales exceed or equal 35
for the year. You therefore want all sales that exceed or equal 35 to appear with a red font
color. In addition, Nicros is your featured product this year so you want those sales to be high-
lighted in yellow so they stand out.

What You Do How You Do It

1. Open Bike Sales Detail 00-01.rpt in Design view. Which cell in the cross-tab represents

the product summary field?

The only one that’s not bold.
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2. Format the fields with value greater

than or equal to 35 and make them

red.

a. In Design view, on the first cross-tab,
right-click the summary field.

b. Choose Format Field.

c. On the Font tab, click the Conditional

Formula button to the right of the Color

drop-down box.

Make sure you click the Color Conditional Formula
button or else the formula that you enter will not
work.

d. Enter the following formula:

If CurrentFieldValue >= 35 then
crRed else DefaultAttribute

e. Check, save, and close the formula.

f. Close the Format Editor.

3. Which field represents the Nicros product sales?

Product.Product Name.

4. Can you use this field in our formula to change the background color to yellow on the

Nicros products?

No. Any field that represents a row or column heading needs to be assigned an alias
before it can be used in a formula.

You may want to encourage
your students to press Enter
before the “then” and “else”
parts of the formula to make
the formula easier to read,
which will make it easier to fix
any mistakes in the formula.

The formula could also be
written If CurrentFieldValue
>=35 then crRed. The use of
the “else DefaultAttribute”
enables the user to control
which font color will appear
when the condition is not met.
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5. Create an alias for the

Product.Product Name field called

Pname.

a. Select the cross-tab and display the

Cross-Tab Expert dialog box.

b. On the Customize Style tab, in the Rows
box, select the Product.Product Name

field.

c. In the Alias For Formulas box, type Pname
and click OK.

6. Enter a formula to make all Nicros

bicycle numbers highlighted with a

yellow background.

a. In the cross-tab, right-click the summary

field.

b. Choose Format Field to display the For-
mat Editor dialog box, and select the

Border tab.

c. Click the Background Conditional For-

mula button and enter the following

formula:

If GridRowColumnValue ("Pname")
like "*nicros*" then crYellow
else DefaultAttribute

d. Check the formula, and then save and

close.

e. Click OK.

7. Preview the report. How has the cross-tab changed?

Any number over 35 is red and the Nicros contain a yellow background.

Save and close the report.

If necessary, remind your
students that the summary

field is the only one that isn’t
bold.
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TOPIC F
Keep Groups Together
After creating a cross-tab, the cross-tab groups may have split across page breaks. In this
topic, you will prevent group headers from being separated from the group detail.

You might find yourself in a situation in which a group header prints at the bottom of one
page and the Details sections start on the following page. To make sure that a single line of
data in a group header doesn’t appear on a line by itself across page breaks, you can make a
simple menu selection to prevent groups from being split.

Figure 2-11: You can specify that a cross-tab not split across pages.

How to Keep Groups Together
Procedure Reference:

To keep groups together:

1. Right-click the group section to display the shortcut menu.

2. Choose Change Group to display the Change Group Options dialog box.

3. On the Options tab, check the Keep Group Together check box.

4. Click OK to close the Change Group Options dialog box.

Keeping Cross-tabs from
Splitting Across Pages
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ACTIVITY 2-7
Keeping Groups Together

Data Files:

• Bike Sales Detail 01-02.rpt

Setup:
No files are open.

Scenario:
You’re getting ready to hand in your cross-tab report so you’re checking it for final changes.
As you can see in Figure 2-12, the date 2002 appears on the bottom of the page by itself. You
need to format the report so the group header appears with the rest of the cross-tab.

Figure 2-12: The report with the 2002 cross-tab heading displayed at the bottom of
page 1.

What You Do How You Do It

1. Preview the Bike Sales Detail

01–02.rpt report.

a. Open the Bike Sales Detail 01–02.rpt

report.

b. Click the Print Preview button.

c. Scroll to view the bottom of the first

page.

d. Notice that the year 2002 appears at the

bottom of the page, but the 2002 cross-

tab appears on the following page.
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2. Specify that the entire 2002 group

is on a page by itself.

a. In Design view, right-click the Group

Header #1A section and choose Change

Group.

b. On the Options tab, check the Keep

Group Together check box.

c. Click OK.

3. Preview the report. a. Preview the report.

b. Notice that the year 2002 now appears

at the top of page 2, above its associ-

ated cross-tab.

c. Save the report.

d. Close the report.

PRACTICE ACTIVITY 2-8
Keeping Groups Together

Objective:
To keep all parts of a group together on the same report page.

Data Files:

• Bike Sales Detail 00-01.rpt

Scenario:
Since the groups in the Bike Sales Detail 01-02.rpt report were not set to stay together, you
decide to check the Bike Sales Detail 00-01.rpt report.

1. Open the Bike Sales Detail 00-01.rpt report.

2. Preview the report to see whether all components of each set of grouped data
appear together on a single page.

3. Specify that all group components appear together on the same page.

4. Save and close the report.
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Lesson 2 Follow-up
Now that you know how to create cross-tabs you’ll be able to analyze large amounts of data to
identify trends to make it easier to understand complex data.

1. How will you use cross-tabs in your job?

Answers will vary.

2. What types of reports do you create that you can present as a cross-tab?

Answers will vary.
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Adding Subreports

Lesson Objectives:
In this lesson, you will add subreports to a report.

You will:

• Insert an unlinked subreport.

• Link a subreport to data in a primary report.

• Edit a subreport.

• Format a subreport object.

• Share formulas between main and subreports.

• Create an on-demand subreport.

Lesson Time
1 hour(s), 30 minutes to
2 hour(s), 15 minutes

LESSON 3
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Introduction
You know how to use a cross-tab to analyze complex data and present different views of the
same data. You can use a subreport to perform those same functions and more using a slightly
different method. In this lesson, you’ll add subreports to your report.

Subreports are especially useful when you need to combine unrelated reports into a single
report. For example, you might want to create a single report that shows sales grouped by
sales representative and sales grouped by item. Subreports enable you to coordinate data that
cannot otherwise be linked and present different views of the same data within a single report.

Another use of subreports is to display data in a one-to-many relationship, with data on the
many side presented in the subreport. For example, you might want to display customer infor-
mation in a main report, and then have customer order information and customer credit
information displayed in subreports.

TOPIC A
Insert a Subreport
Up to this point, you’ve worked with reports where the data is related and linkable. There
might be times when you have unrelated data (data that cannot be linked) that you need to
combine into a single report. In this topic, you’ll insert a subreport into a primary report.

Let’s say you have two entirely different sets of data that you want to combine into a single
report. For example, you want to combine the school’s football statistics with the basketball
statistics. An unlinked subreport is the perfect solution since the data exists in unrelated tables.

Figure 3-1: You can insert a report within another report.

A Subreport
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Plan Subreports
Before you start to create a subreport, you might want to have a plan first. In the planning
stage, you will use the following list to get an idea of what you want to create before you cre-
ate it.

• Determine why and if you need to create a subreport in order to display the data.

• Examine the data in both databases to see how they can be combined.

• Determine where the subreport will be located (which report section).

• Determine which link fields, if any, will be used.

• Determine what filter criteria, if any, needs to be in the subreport.

How to Insert a Subreport
Procedure Reference:

To insert a subreport:

1. If you want to place the subreport in a section that doesn’t yet exist, then create
the new section.

2. Choose Insert→Subreport to display the Insert Subreport dialog box.

3. Select Choose An Existing Report and browse to locate the name of the report
you wish to insert and click Open. (If you know the name and location of the
report you can type it.)

4. Click OK to display an object frame and the mouse pointer.

5. Place the mouse pointer where you want the report to appear and click to place it.

ACTIVITY 3-1
Inserting a Subreport

Data Files:

• Adult Bikes.rpt

• Kidsbikes.rpt

Setup:
No data files are open.

Scenario:
You have a report that shows all adult bike sales for 2001 and 2002. You have a second report
that shows children’s bike sales. You have been asked to combine this information on one page
for your company’s annual report. Figure 3-2 displays how the combined report will appear.
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Figure 3-2: One report containing both adult and kid bike sales.

What You Do How You Do It

1. In Adult Bikes.rpt, create a Report

header below Report Header B to

contain the subreport.

a. In Adult Bikes.rpt, on the Design tab,
right-click Report Header B.

b. Choose Insert Section Below.

2. Insert the subreport Kidsbikes.rpt

in the Report Header C section.

a. Choose Insert→Subreport.

b. Select Choose An Existing Report,

browse to and select Kidsbikes.rpt, and

click Open.

c. Click OK.
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d. Place the mouse pointer in the Report

Header C section and click.

e. Preview the report.

3. What design changes might be made to the subreport object?

Remove the border.

4. How many tabs appear in this report?

Three. The subreport has its own tab.

5. Use the Border button to change

the line style of the subreport bor-

der to No Border.

a. Select the Kids’ Bike Sales subreport.

b. On the Formatting toolbar, click the

down arrow next to the Border button.

c. Click No Border.

d. Preview the report to verify that the

borders are removed.

e. Save and close the report.
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TOPIC B
Link a Subreport to Data in a Primary
Report
It’s very common for data in the subreport to be linked to the data in the primary report.
Subreports provide an easy way to link data that cannot otherwise be linked. Subreports easily
display information in a one-to-many relationship without having to worry about duplicated
data. In this topic, you’ll link a subreport to data in a primary report.

Not only is it helpful to have a linked subreport to show more information, you can also use a
link to your advantage to limit information. For example, let’s say you have customer data in a
primary report and then use subreports to show the orders for each customer. The link will
coordinate the data in the primary report with the data in the subreport so that the orders in
each subreport match up with the correct customer. You can also pass filter criteria to a
subreport using links to the main report in order to limit the information displayed in the
subreport.

How to Link a Subreport to Data in a Primary
Report
Procedure Reference:

To link a subreport to data in a primary report:

1. Choose Insert→Subreport to display the Insert Subreport dialog box.

2. Select Choose An Existing Report and browse to locate the report you want to
insert and click Open. You could also type the name of the report.

3. Select the Link tab.

4. In the Available Fields list box, select the field that you want used as a link field
in the primary report and click the arrow button.

5. Confirm that the correct link field from the subreport is displayed in the lower-
right corner.

6. Repeat steps 4 and 5 for each additional link.

7. Click OK to close the Insert Subreport dialog box.
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ACTIVITY 3-2
Linking a Subreport to Data in a Primary Report

Data Files:

• US Customers.rpt

• US Suppliers.rpt

Setup:
No reports are open.

Scenario:
You have a report that shows all customers in the USA grouped by region. The data source for
this report is the xtreme.mdb customer table. You have another report that shows all suppliers.
The data source for that report is the xtreme.mdb suppliers table. You need to combine the
data from both of these reports into one report with the suppliers appearing in the appropriate
region grouping beneath the customer list.

What You Do How You Do It

1. In US Customers.rpt, where would you want to put the supplier information on your

report?

In the region group footer.
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2. In US Customers.rpt, insert the

subreport US Suppliers.rpt in the

Group Footer #1 section, link by

the region field, and then preview

the report.

a. Choose Insert→Subreport.

b. Select Choose An Existing Report,

browse to and select US Suppliers.rpt,

and click Open.

c. Select the Link tab.

d. On the Link tab, add Customer.Region as

the link field.

e. Click OK.

f. Place the mouse pointer in the Group

Footer #1 section and click to insert the

subreport.

g. Preview the report.

3. How has the report changed for Michigan and Oregon?

Only MI and OR have suppliers listed. The rest of the states display a box with just the
word “suppliers” in it.

This will be corrected in the next activity. Save the report.

To preview the report, be sure
that your students click the

Print Preview button, and not
the US Suppliers.rpt tab,

which they may mistake for
the Preview tab.
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TOPIC C
Edit a Subreport
After adding a subreport within another report, you may want to select and edit the subreport.
In this topic, you will open a subreport within a separate tab so you can edit the subreport.

You cannot directly edit a subreport within the Design or Preview tabs. However, you may
want to be able to edit the subreport directly within the primary report file in which you’ve
placed it. The ability to display the subreport within its own tab will allow you to access and
modify the report components.

Figure 3-3: This report includes a subreport containing a cross-tab, whose formatting
was modified to match the primary report’s cross-tab.

How to Edit a Subreport
Procedure Reference:

To edit a subreport:

1. In Design view, right-click the subreport and choose Edit Subreport to display the
Design tab of the subreport.

Report header/footer sections might not appear on the report because they are collapsed. Posi-
tioning the cursor on the border of the section and dragging will open the section so it can be
viewed and/or deleted.

Format a Subreport
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2. Make any necessary changes to the subreport.

ACTIVITY 3-3
Editing a Subreport

Setup:
The report US Customers.rpt is open.

Scenario:
You inserted a subreport into a primary report and noticed that it needs some changes. There is
too much white space, and the “Supplier” header appears when there are no suppliers. You will
edit the subreport to make the changes as shown in Figure 3-4.

Figure 3-4: A portion of the report after editing.
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What You Do How You Do It

1. In the subreport of the US
Customers.rpt, delete any extra sec-

tions so that you only have one RH

and RF.

a. In Design view of US Customers.rpt, right-

click the subreport and choose Edit

Subreport.

b. Right-click any extra Report Header.

c. Choose Delete Section.

d. Right-click any extra Report Footers and

choose Delete Section.

e. Preview the report.

2. How has the report changed?

Extra white space has been eliminated.

3. Move the Supplier object so it is

aligned with the Customer data.

a. On the Design tab, drag the Supplier

object so it is lined up as closely as pos-

sible with the Customers object.

b. If you can’t align the objects precisely by
dragging, select both objects, and

choose Format→Align→Left.

4. Does the Suppliers subreport title appear on all records even when there are no sup-

pliers?

Yes, it appears on all records, even when there are no suppliers.

This will be corrected in a later exercise.

5. How can you determine the number of suppliers?

Format the subreport.
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TOPIC D
Format a Subreport Using the Format
Editor
You know how to edit the main report that contains a subreport, to align objects, and remove
unwanted white space to produce a more consistent look. But what about the appearance of the
subreport itself? In this topic, you’ll focus on blending the subreport with the rest of the main
report by specifying options in the Format Editor.

A subreport becomes an object on the main report. Formatting a subreport object allows the
object container in the main report to be changed. For example, you can use the Format Editor
dialog box to change borders, colors, fonts, on-demand actions, and re-import options to visu-
ally change the appearance of your subreport.

Figure 3-5: You can open the Format Editor to edit a subreport.

Re-import When Opening
Subreports are typically created from existing reports. It is not unusual for multiple main
reports to share the same subreport. When changes are made to one subreport the user might
want those changes propagated to all the main reports that use the same subreport. This is pos-
sible by checking the Re-import When Opening option on the Subreport tab of the Subreport
Format Editor.

The Format Editor for a
Subreport

LESSON 3

Crystal Reports 10.0: Level 274



FO
R 

EV
AL

UA
TI

O
N 

US
E 

O
NL

Y

DO
 N

O
T 

DU
PL

IC
AT

E

(C
) 2

00
4

El
em

en
t K

Co
nt

en
t L

LC

However, if you want to retain any editing changes made to the subreport after import, the
check box must be unchecked. Failure to do so will result in a loss of editing changes.

How to Format a Subreport Using the Format
Editor
Procedure Reference:

To format a subreport using the Format Editor:

1. In Design view, right-click the subreport to display the shortcut menu and choose
Format Subreport to display the Format Editor dialog box. Alternatively, you
could select the subreport object and choose Format→Format Subreport.

2. Make any necessary changes to the following tabs.

a. Use the Common tab to set properties like Suppress, Horizontal Alignment,
and Keep Object Together for a desired field.

b. Use the Border tab to format the borders, background fill, and drop shadows
for selected fields on your report.

c. Use the Subreport tab to select or clear the On-demand subreport and
Re-import when opening options.

d. Use the Font tab to change the fonts, the font size, and the font style for text
and data fields on your reports.

3. Click OK to close the Format Editor. Use the Subreport tab to select or clear the
On-demand Subreport and Re-import When Opening options. This tab also allows
you to suppress subreport objects when the subreport returns no data.

ACTIVITY 3-4
Formatting a Subreport Object

Setup:
US Customers.rpt is open.

Scenario:
You’re getting ready to submit your report and need to put some of the finishing touches on it.
The borders on the subreport create an empty box when there are no suppliers so you will
remove the borders. You also want to ensure that the changes you have made in your subreport
will not be overridden the next time you open the report. When you’re finished, your report
should look like Figure 3-6.
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Figure 3-6: Applying finishing touches to the subreport.

What You Do How You Do It

1. Remove the borders from the

subreport.

a. In Design view, right-click the subreport

and choose Format Subreport.

b. Select the Border tab.

c. In the Line Style section, from each of the
drop-down lists, select None.

2. Ensure that the subreport and any

changes you’ve made to it will be

re-imported each time the report is

opened.

a. Select the Subreport tab.

b. Check the Re-import When Opening

check box.

3. Suppress the subreport when there

are no records.

a. On the Subreport tab, select Suppress

Blank Subreport.

b. Click OK.
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4. What has changed in the report?

The borders are removed, and the subreport no longer appears when there are no
suppliers. However, there is still white space in the report where a blank subreport
exists.

5. Suppress Group Footer #1 when

blank.

a. Right-click the gray area of Group

Footer #1, select Section Expert, and

check Suppress Blank Section.

b. Click OK.

c. Save the report.

d. Preview the report.

TOPIC E
Share Formulas Between Main and
Subreports
You have seen that subreports operate independently from the main reports with their own sec-
tions, data, and formulas. In running totals, you used the same variable in multiple formulas,
essentially sharing the result of one formula with another. In this topic, you will share a for-
mula between the main and the subreport.

Summaries are often presented at the ends of reports and it isn’t uncommon to display infor-
mation from subreports in those summaries. You might also want to format a main report
based on formula results in the subreport. For example, let’s say you are using two subreports
on a customer invoice; one subreport displays order information, the other displays credits.
You would like the words “Invoice with credits applied” to appear at the top of the invoice
when there are credits. If there are no credits, you simply want the word “Invoice” to appear.
A formula using shared variables can be used to extract the necessary information from the
credit subreport.

The Count Function
The Count function enables you to count the values that appear in your report (with the excep-
tion of nulls) for a specified field. For example, Count({OrderDetail.ProductType}) would
return a count of the number of records in the OrderDetail table where the ProductType field
was completed. If the product type field was not completed, it would not be included in the
count. Counting can only occur against records that actually exist and that have a value in the
field being counted.

It is common to use the count function to determine whether a subreport will return any
records. If no records are found in the subreport, the count function would return a null value
rather than a zero.
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Shared Variables
Crystal Reports provides the shared variable to enable you to pass data back and forth
between main reports and subreports or even subreport to subreport. In order to use a shared
variable, you must declare the variable and assign it a value before it can be used between the
main and subreport. In order to declare a variable, you need to create a formula that declares
the same shared variable in both the main and subreport.

Variable Scope
Variable scope is used to define the degree in which variables in one formula are made avail-
able to other formulas. Every variable has a scope which is specified when the variable is
declared. The contents of a variable can be used throughout a report. By default, any variable
created in Crystal Reports is assigned a global scope, meaning that the variable contents
remain available throughout the report. There are two other types of scope used with Crystal
Reports variables: local and shared. The following table summarizes the difference in each.

Crystal Reports Variable
Scope Description Example
Global Variable contents remain

available for the entire
report.

Global StringVar MyVar; (Note: use of the
word global is optional. All variables are
global by default when using Crystal
Syntax.)

Local Variable contents are only
available within the formula
in which it is created.

Local StringVar MyVar;

Shared Variable contents remain
available for the entire report
and Any subreports.

Shared StringVar MyVar;

The textbook covers Crystal Variable Scopes. Basic syntax uses different terminology. See the Crystal Help
Screens for information on Basic syntax scope.

How to Share Formulas Between Main and
Subreports
Procedure Reference:

To share formulas between main and subreports:

1. If the formula already exists, simply add the word “shared” before the variable
declaration portion of the formula (for example, shared numberVar MyCount).

2. If you are creating a new formula, add the word “shared” before the variable dec-
laration portion of the formula.

Variable Scope
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Suppressing Empty Sections
The Section Expert is used to format entire sections of your report. By selecting a sec-
tion of the report in the Section Expert, you can view and set formatting properties for
the section. Depending on which section you select, properties will vary and some
won’t be available. The Suppress Blank section suppresses the entire section of all the
objects inside it that are blank. This is useful in situations where you want to avoid
white gaps in the report.

ACTIVITY 3-5
Sharing Formulas Between Main and Subreports

Setup:
US Customers.rpt is open.

Scenario:
You have a report that lists customers and suppliers within each region. You would like to
include a summary statement that shows the total number of customers and suppliers in each
region.

Figure 3-7: Showing a count of customers and suppliers.
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What You Do How You Do It

1. How can you determine the total number of customers?

You could do a count of customers in the main document.

2. How can you determine the total number of suppliers?

This is already done for you in the subreport report footer.

3. Can you use the results of the supplier count formula in your main report?

No. You would need to create the formula using a shared variable.

4. In the subreport, create a formula

called SupplierCount that can be

shared with the main report.

a. On the subreport’s tab, create the fol-

lowing formula named SupplierCount

b. If necessary, drag to increase the size of

the Report Footer.

c. Drag the SupplierCount formula into the

Report Footer.

d. Suppress the subreport’s report footer.

5. Does this change the main report?

No. The formula results are in a suppressed report footer.

You will use that report to create a statement showing the number of customers versus the number of suppliers.

6. In the main report, create a formula

called SummaryText that indicates

how many customers and suppliers

exist in each state.

a. Enter the following formula named

SummaryText

b. Check the formula, and then save and

close.

7. Why wouldn’t you place the formula in the Group Header?

If the formula was positioned in the Group Header, the totals would refer to the previous
group in the report. Positioning within the report becomes critical when working with
shared variables.
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8. Place the formula in a new group

footer #1b section and preview the

report.

a. Right-click the group footer and choose

Insert Section Below.

b. From the Field Explorer, drag

SummaryText to the new group footer

#1b section.

c. Preview the report.

d. Notice that a customer and supplier

count appears on the report, as shown

in Figure 3-7.

e. Save and close the report.

TOPIC F
Create an On-demand Subreport
You’ve seen several completed subreports that display their data in the primary report. But
what if you want to build a subreport and not display the data until you’re ready? In this topic,
you’ll create a subreport that appears as a link and doesn’t display or take data from the server
until you request it.

You might have noticed that you have to wait a few seconds for the subreport to display in the
primary report. Depending on the size of data on which you’re reporting, your wait could be
quite lengthy. By creating an on-demand subreport, you can minimize network traffic by for-
matting a subreport to display only when you specifically request the data via a link.

Figure 3-8: An on-demand subreport appears on the report as a link.

An On-demand Subreport
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On-demand Subreport
An on-demand subreport appears as a link in the main report so that it doesn’t process until a
user clicks the link. Performance can be an issue when working with subreports, especially if a
report contains several subreports. If users need to see subreport data only occasionally, mak-
ing a subreport available“on-demand” will minimize network traffic. The data in the subreport
will not be taken off the server until the user clicks the “on-demand” link. The use of
on-demand subreports also frees space on your main report.

On-demand subreports open in their own Preview tab. The name of the link and the text on the
tab can be customized by the user.

When data is saved with a report that includes an on-demand subreport, the subreport data will not be saved
with the report unless the subreport Preview tab is open.

How to Create an On-demand Subreport
Procedure Reference:

To create an on-demand subreport.

1. Choose Insert→Subreport to display the Insert Subreport dialog box.

2. Select Choose An Existing Report or Create A Report.

3. Check the On-demand Subreport check box to activate the command.

Existing subreports can be modified to be on-demand subreports by checking the on-demand
subreport option in the Subreport Format Editor.

4. Click the conditional Formula button to add a caption to the subreport object.

5. Type the text that you want as the caption, and be sure to place quotes around the
string.

6. If applicable, check the formulas created in steps 4 and 5 above, then click the
Save And Close button to return to the Format Editor dialog box.

7. Click OK to close the Insert Subreport dialog box.

PrintDate Function
PrintDate is a Crystal Report function that returns the system date of the PC being
used. Users can override the system print date by using the Report, Set PrintDate/Time
menu bar option. The override feature is particularly helpful when testing output that
relies on date selection formulas.
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ACTIVITY 3-6
Creating an On-demand Subreport

Data Files:

• Contacts.rpt

• Phonelist.rpt

Setup:
No files are open.

Scenario:
You’ve created a report that lists the names and addresses of customers and suppliers. You
would like to add a list of suppliers’ phone numbers at the end of the report and know that
you can do so by adding a subreport based on the phonelist.rpt file. You’ll make the subreport
appear as a link and click the link only when you need the phone information.

What You Do How You Do It

1. In Contacts.rpt, add an on-demand

subreport in the report footer dis-

playing the file named Phonelist.

rpt.

a. In Contacts.rpt, in Design view, open the

Insert Subreport dialog box, and specify

the file named Phonelist.rpt.

b. In the Insert Subreport dialog box, check

the On-demand Subreport check box

and click OK.

c. Place the subreport in the Report

Footer.
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2. Format the subreport to include an

on-demand subreport caption Sup-

pliers Phone List and a subreport

preview tab caption that reads Sup-

pliers as of (today’s date).

a. Right-click the Phonelist subreport.

b. Choose Format Subreport.

c. On the Subreport tab, click the Condi-

tional Formula button to the right of

On-demand Subreport Caption.

d. Type “Suppliers Phone List” and save

and close the Formula Editor.

e. On the Subreport tab, click the Condi-

tional Formula button to the right of

Subreport Preview Tab Caption.

f. Type “Suppliers as of ” & PrintDate and

save and close the Formula Editor.

g. Click OK.

3. Where is the link displayed?

The last page.

4. Test the on-demand subreport. a. Deselect the subreport.

b. Click the link.

c. Notice that the subreport is displayed

and the on-demand subreport preview

tab includes a caption.

d. Save and close the report.
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Lesson 3 Follow-up
Now that you know how to create subreports, you’ll never have to struggle to combine unre-
lated reports into a single report or coordinate data that cannot otherwise be linked.

1. How will you benefit by using subreports in your office?

Answers will vary.

2. What kinds of subreports will you be creating?

Answers will vary.
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Creating Drill-downs

Lesson Objectives:
In this lesson, you will design a report that uses a drill-down.

You will:

• Create a report that includes summaries with drill-down data.

• Specify that drill-down data headings appear with the drill-down data.

Lesson Time
1 hour(s) to 1 hour(s),
15 minutes

LESSON 4
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Introduction
As you create reports that include data summaries, you may want to specify that only the sum-
mary data is visible initially, with the detail data available as a drill-down. In this lesson, you
will create a report so that it initially displays summary data, with the additional data acces-
sible via drill-down.

Suppose you are creating a report to display the total salary expenses for each department in
your company. Although you only want the report to primarily display the summary informa-
tion, you also want the detail data on which the summary data is based to be accessible via
drill-down. That way, viewers will be able to easily scan the report to view the total salary
amounts for each department, and can then drill-down to view the individual salaries for each
employee within a given department.

Figure 4-1: A drill-down report allows you to display detail data separately from sum-
mary data.

A Drill-down Report
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TOPIC A
Create a Drill-down
When you want to create a report that initially displays summary data, with the rest of the data
available by double-clicking the summary data, then you must create a drill-down. In this
topic, you will structure a report as a drill-down.

Creating a drill-down report is useful when your report contains large amounts of data that you
want to summarize so that only the data summaries themselves appear initially. That way,
people viewing your report can easily see the most important data. However, the drill-down
structure allows viewers to easily locate the detailed data on which any given summary is
based.

Figure 4-2: This report’s preview tab displays only summary data, and you must drill-
down to view the detail data.

Drill-down Report Structure
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How to Create a Drill-down
Procedure Reference:

To create a report that includes summaries with drill-down data:

1. Create a new report that includes the desired data.

2. Create summaries for the desired fields.

3. Insert a group to display the summary data.

4. In the Details section, add the data that should only appear when viewers drill-
down.

5. Specify that the Details section be hidden, with its contents available via drill-
down.

• In Design view, right-click within the gray area at the left side of the Details
section, and from the shortcut menu, select Hide (Drill-Down OK).

• In the Section Expert, select the Details section, then check the Hide (Drill-
Down OK) check box.

6. If you want to view the drill-down data, then while previewing the report, double-
click the summary data whose detail data you want to view. The detail data then
opens in its own tab.

7. If you want to close the tab displaying the drill-down data, then while viewing the
drill-down data, click the Close View button.

ACTIVITY 4-1
Creating a Drill-down

Data Files:

• xtreme.mdb

Setup:
Crystal Reports is running, with no reports open.

Scenario:
You’re creating a report for your next sales meeting. The primary purpose of the report is to
display the total order amounts for each customer. However, during the meeting, you may need
to also access some of the data for an individual sale. The data you need is stored in the
xtreme.mdb database, within the Customer and Orders tables.
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What You Do How You Do It

1. Create the report. a. Choose File→New, select As A Blank

Report, and click OK.

b. From the xtreme.mdb data source, select

the Customer and Orders tables, then

click OK.

c. The Links tab indicates that the tables are
linked by the Customer ID field. Click OK.

2. Summarize the Order Amount field,

grouping the report by customer.

a. On the Insert Tools toolbar, click the

Insert Summary button .

b. From the Choose The Field To Summarize
drop-down list, select Order Amount.

c. From the Calculate This Summary drop-
down list, verify that Sum is selected.

d. You will create a group in which to store
the summary data. Click Insert Group.

e. In the Insert Group dialog box, from the
top drop-down list, select Customer

Name, then click OK.

f. You return to the Insert Summary dialog
box. Click OK.
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g. Move the summary data into the group

header section.

3. Save and preview the report. a. Save the report as Customer Sales
Totals

b. Preview the report.

c. Position the cursor on the report sum-

mary data.

d. The drill-down cursor appears. Double-

click to view the drill-down data.

4. What happens when you double-click to drill down?

You still view only the summary data for the item you double-clicked. A new tab appears
to display this data individually.

Click the Close View button to close the drill-down tab.

5. Add the Customer Name, Order

Date, and Order Amount data to the

Details section.

a. Return to Design view.

b. In the Field Explorer, expand the Cus-

tomer table.

c. Drag the Customer Name field to the left

side of the Details section.

d. Drag the Order Date field to right of the

Customer Name field.

e. Drag the Order Amount field to the right

of the Order Date field.

f. Format the Order Date to display only

the date.
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g. Preview the report.

6. Specify that the Detail section be

hidden, with its contents accessible

via drill-down.

a. On the Expert Tools toolbar, click the

Section Expert button .

b. In the Sections list, select Details.

c. Check the Hide (Drill-Down OK) check

box.

d. Click OK.

e. Save the report.
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7. View the drill-down data. a. Position the mouse pointer on the sum-

mary data for Alley Cat Cycles.

b. The drill-down cursor appears. Double-

click to view the drill-down data.

c. Click the Close View button to close the

tab displaying the drill-down data.

8. What problem do you notice with the report headings in the Page Header section?

The three field headings that appear in the Page Header section, Customer Name, Order
Date, and Order Amount, display with the summary data, rather than with the drill-down
data.

You will fix this in the next topic.
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TOPIC B
Create Separate Headings for Drill-
down Data
After creating a report that includes drill-down data, you may need to specify that different
headings appear for the drill-down data than for the summary data. In this topic, you will
specify that separate headings appear when the drill-down data is displayed.

When you add fields to the Details section, corresponding headings typically appear above
each field in the Page Header section. However, if you then hide the Details section data so
that it only appears when you drill-down, then the corresponding headings will still display in
the Page Header with the summary data, rather than with the drill-down data. The ability to
create separate headings for the drill-down and summary data ensures that the correct headings
appear with each report component.

Figure 4-3: You can use conditional formulas to suppress specified sections when dis-
playing a given drill-down level.

Separate Headings for Drill-
down Data
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Drill-down Level Numbering
A report can contain several levels of drill-downs. Each drill-down level can be identified
numerically within formulas using the DrillDownGroupLevel function. For example, if a report
includes two drill-down levels, then the primary report preview displaying the summary data
can be identified using the formula DrillDownGroupLevel = 0. The first drill-down can be
identified using the formula DrillDownGroupLevel = 1, and the second drill-down can be iden-
tified using the formula DrillDownGroupLevel = 2. The DrillDownGroupLevel function can be
useful in conditional formulas, for example, to suppress a particular report section when a
specified drill-down level is viewed.

How to Create Separate Headings for Drill-down
Data
Procedure Reference:

To specify that drill-down headings display only with the drill-down data:

1. Create a second Group Header section.

2. Add the drill-down data headings to the new Group Header section.

3. In the Section Expert, select the new Group Header section that contains the drill-
down data headings.

4. Next to the Suppress (No Drill-Down) check box, select the Conditional Formula
button.

5. In the Formula Workshop, enter the formula DrillDownGroupLevel = 0. This indi-
cates that the Group Header section should be suppressed in the primary report
preview.

6. If the report includes another Group Header section that should not appear with
the drill-down data, then in the Section Expert, select that Group Header, select
the Conditional Formula button next to the Suppress (No Drill-Down) check box,
and specify the formula DrillDownGroupLevel = 1. This indicates that the Group
Header section should be suppressed in the first drill-down level.

LESSON 4

Crystal Reports 10.0: Level 296



FO
R 

EV
AL

UA
TI

O
N 

US
E 

O
NL

Y

DO
 N

O
T 

DU
PL

IC
AT

E

(C
) 2

00
4

El
em

en
t K

Co
nt

en
t L

LC

ACTIVITY 4-2
Creating Separate Headings for Drill-down Data

Scenario:
The report you created for the sales meeting is almost finished. However, the field headings
that should appear with the drill-down data are instead appearing with the summary data. In
addition, the summary data appears with the drill-down data, which is unnecessary.

What You Do How You Do It

1. Place the drill-down data field

labels in a new Group Header

section.

a. In Design view, position the mouse

pointer in the Group Header section’s

gray area.

b. Right-click the Group Header, and select

Insert Section Below.

c. In the gray area of the Page Header sec-
tion, right-click, and from the shortcut

menu, choose Select All Section Objects.

d. Press the Down Arrow key until the

three selected items move to the Group

Header #1b section.

e. Preview the report.

f. Notice that the labels in the new Group

Header section display with the drill-

down data, but also still display with the

summary data.
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2. Specify that the new Group Header

section should be suppressed when

you preview the summary report

data.

a. Close any drill-down data tabs.

b. Open the Section Expert dialog box.

c. Select the Group Header #1b section.

d. Next to the Suppress (No Drill-Down)

check box, select the Conditional For-

mula button.

e. In the Formula Workshop, enter the for-

mula DrillDownGroupLevel = 0

f. Check the formula, then save and close

it.

g. In the Section Expert dialog box, click OK.

h. Preview the report data, and notice that

the three headings no longer appear.

i. Double-click the Alley Cat Cycles sum-

mary data to view the drill-down, and

notice that the three headings now

appear.

3. The summary data appears above the drill-down data. How could you specify that the

summary data not display with the drill-down data?

The summary data appears in the Group Header #1a section. You could specify a condi-
tional formula to suppress the Group Header #1a section when you display the drill-down
data. The formula you would use is DrillDownGroupLevel = 1.

4. Specify that the report summary

data not appear with the drill-down

data.

a. Close any drill-down data tabs.

b. In the Section Expert, select the Group

Header #1a section.

c. Next to the Suppress (No Drill-Down)

check box, select the Conditional For-

mula button.

d. In the Formula Workshop, enter the for-

mula DrillDownGroupLevel = 1

e. Check the formula, then save and close

it.

f. In the Section Expert dialog box, click OK.
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g. On the Preview tab, double-click the

Alley Cat Cycles summary data to view

the drill-down, and notice that the sum-

mary data no longer appears at the top.

5. For the main preview of the sum-

mary data, add the heading

Customer Sales Totals

a. Click the Preview tab.

b. Select the Insert Text Object tool, then

click within the Page Header section.

c. Type Customer Sales Totals

d. Format the heading as 14 pt bold.

e. Position the heading at the left edge of

the Page Header section.
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6. Move the Customer Name field to

the Group Header #1b section.

a. In Design view, in the Group Header #1b
section, delete the Customer Name

label.

b. In the Details section, select the Cus-

tomer Name field.

c. Press the Up Arrow key to move the

field into the Group Header #1b section.

d. Increase the height of the Group Header

#1b section to a bit more than twice its

original size.

e. Move the Order Date and Order Amount

labels to the bottom of the Group

Header #1b section.

f. Move the Order Date and Order Amount

fields and their labels to the left.

g. Format the Customer Name field to dis-

play with bold formatting.

h. Preview the report’s summary data and

drill-down data.

i. Save and close the report.
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Lesson 4 Follow-up
You now know how to create a drill-down report. The ability to specify a drill-down report
allows you to create summary reports that don’t overwhelm the viewer with too much data,
while also allowing them to quickly access the detailed data.

1. For what types of data might you create drill-down reports in your own work?

Answers will vary.

2. What aspects of this lesson will be most useful in your own work?

Answers will vary.
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Enhancing Report
Processing Using SQL

Lesson Objectives:
In this lesson, you will improve processing speed in your reports.

You will:

• Create a report that accesses data using an SQL query.

• Summarize report data using an SQL aggregate function within an SQL query.

• Specify SQL queries that join tables.

• Create queries that include subqueries.

• Create an SQL Expression field.

Lesson Time
1 hour(s), 15 minutes to
1 hour(s), 45 minutes

LESSON 5
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Introduction
You have used Crystal Reports to add and link tables for your reports, as well as to filter and
sort the report data. As you work with larger and more complex reports, the tools provided by
Crystal Reports may not be sufficient to meet all of your needs. In this lesson, you will create
SQL commands and expressions to allow Crystal Reports to process data more efficiently, and
to perform reporting tasks not otherwise possible.

Writing your own SQL commands and expressions within Crystal Reports can increase perfor-
mance and provide more flexibility than is offered by the Crystal Reports tools alone.

TOPIC A
Create a Report Using SQL Queries
When you create a new report, you may want to write SQL queries to specify the report data
you want to display. In this topic, you will create a report by specifying a simple SQL query.

Accessing data for a report by writing an SQL query is often the most efficient way to acquire
the report data, since the SQL query ensures that the data processing will occur on the remote
database server, rather than on your computer. In addition, if you’re familiar with SQL, you
may prefer to write SQL queries to access the data you want, rather than specify commands
within Crystal Reports to display the data you want.

Server-side Processing
Definition:

Server-side processing is report processing that is carried out on the remote server con-
taining the database, rather than on the client computer that accesses the server
remotely. Server-side processing applies to reports that need sorting, filtering, grouping,
and/or totaling, and works only for reports based on SQL data sources.
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Example:

Figure 5-1: Server-side processing frees up the client computer to perform
other tasks.

Factors Affecting Server-side Processing
Many factors in a report can prohibit or restrict the amount of processing that can be done on
a server. In an ideal world, all record selection, sorting, grouping, and totaling would be done
at the server level. Unfortunately, the use of many of Crystal Reports’ most valuable features
results in situations where processing cannot be done on the server. In some cases, only partial
server processing can be done. Reports with drill-down capability, running totals with vari-
ables, specified grouping, or Crystal Reports functions are just a few examples of some of the
factors that will inhibit server-side processing. Specifying report tasks using SQL can greatly
enhance the likelihood that processing will occur on the server.

SQL
Definition:

SQL, or Structured Query Language, is the standard query language by which people
access and manipulate relational database data that is stored on a computer network.
When using Crystal Reports to access data from SQL and ODBC database sources, the
filters, sorts, groups, and totals you specify are converted by Crystal Reports to SQL
statements in an attempt to communicate directly with the database to retrieve records.
In addition, you can manually write out SQL statements within Crystal Reports. SQL
expressions can always be interpreted by the underlying database. However, formulas
that are built with Crystal Reports functions and operators often require all the data to
be brought into the Crystal Reports report engine for processing.

Server-side Processing
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Example:

Figure 5-2: Many commands you specify in Crystal Reports are converted to
SQL statements used to access data.

SQL Benefits
A primary benefit of using SQL queries within Crystal Reports is that the remote SQL data-
base uses the query to locate and isolate only the data you’ve requested, and then sends only
that data to your computer. Since the processing occurs on the remote server, and only the
requested set of data is sent to your computer, your computer’s resources are available for
other tasks. Remember that the Crystal Reports engine converts many of your Crystal Reports
commands to SQL automatically, so in many cases, it is not necessary to manually enter the
SQL yourself. However, since formulas built with Crystal Reports functions and operators
often require that the data be brought into Crystal Reports for processing, there are times when
you must create the SQL yourself if you want the data to be processed by the SQL server.

Another benefit of using SQL queries within Crystal Reports is that you can at times use them
to access data in a way not possible using the commands in Crystal Reports. In these cases,
you will manually enter the SQL.

SQL
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Applications Using SQL
Many applications support the use of SQL in order to access and manipulate SQL databases. In
applications supporting SQL, the user may write out SQL statements manually, or may select
options that the software converts to SQL statements, or both. SQL is a standardized language,
which means that specific features must be present in any version of SQL used within a given
software application. However, many applications that support SQL actually use a customized
version of SQL to allow for advanced capabilities not available in standard SQL.

SQL Clauses
Definition:

SQL clauses are the components of an SQL statement that you use to indicate the task
you want the database to perform.

Example:

Clause Required Purpose
SELECT Yes Indicates the names of the fields whose data

you want to retrieve.

FROM Yes Indicates the table containing the field data
you want to retrieve.

WHERE No Sets record filter criteria.

GROUP BY No Establishes grouping.

HAVING No Sets group filter criteria.

ORDER BY No Determines sort order.

For querying data, only the SELECT and FROM clauses are required for all queries.
You can use other clauses to get more control over the data you’re retrieving.

The DISTINCT Keyword
When the DISTINCT keyword appears within the SELECT clause, it indicates that
only unique data values will be retrieved, without repetitions. For example, the follow-
ing statement would retrieve only one repetition of each customer name from the
Purchases table, even though that table may contain many repetitions of each customer
name:

SELECT DISTINCT custname
FROM Purchases

SQL Statements
Definition:

An SQL statement is a request written using SQL clauses that is sent to a server con-
taining an SQL database, and directs the server to perform specific database tasks. You
can use SQL statements to create a database file, add tables and fields to a database,
add records to tables, or retrieve data from databases.

SQL Clauses
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Example:
One type of SQL statement is an SQL query, which requests data from an SQL
database. This is the only type of SQL statement you will use in this course. A query
must include both the SELECT and FROM clauses, but may also include additional
clauses. The SELECT clause keyword is followed by the name of the field or fields
you want to retrieve, with each field separated by a comma. The FROM clause key-
word is followed by the name of the table containing the field or fields you want.

Figure 5-3: This simple SQL statement uses only the SELECT and FROM clauses.

The * Character
When the * character appears following the SELECT clause keyword, the SQL state-
ment will retrieve all fields in the specified table. For example, the following SQL
query would retrieve all fields from the Orders table. When you want to retrieve all
fields in a table, using the * character saves you from having to type out the names of
all the fields.

SELECT *
FROM Orders

SQL Rules
• When creating an SQL query, the clauses you use must appear in this order: SELECT,

FROM, WHERE, GROUP BY, HAVING, ORDER BY. Only the SELECT and FROM
clauses must be included in all queries, but for all clauses that are used, they must follow
this order. Some people find it useful to remember the acronym SoFtWareGHOst as a
reminder of the correct order of the clauses. The uppercase characters in the acronym rep-
resent the query clauses.

• You must type a space after each clause keyword, such as SELECT and HAVING.

• When a SELECT clause specifies multiple fields, you must type a comma between each
field.

SQL Statements
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• Table and field names that include more than one word separated by a space must be
entered within ′ (grave) characters, quotation characters, or brackets [ ]. The grave charac-
ter, also known as a back tick, is typed using the key near the keyboard’s top left,
typically next to the 1 key. A report generated from a Microsoft Access connection uses
the grave mark, and so in this case quotation marks will not be interpreted correctly if
added around field or table names containing spaces. When Crystal Reports generates
SQL statements based on Crystal Reports commands you specify, the grave or quotation
characters are added automatically to field and table names, regardless of whether the
names include spaces.

• If a referenced field uses a name that is also used by other fields in other tables within the
database, you must precede the field name with the table name and a period, as in

SELECT Contacts.Name
FROM Contacts

SQL Conventions
There are several SQL conventions that are not strictly necessary, but that should be followed
to ensure your Crystal Reports SQL queries are clear and effective.

Convention Example
Clause keywords appear using uppercase characters so they
are easily distinguishable among the other components of
the statement.

SELECT Amount
FROM Orders

Each clause appears on its own line to keep the statement
from becoming confusing to read.

SELECT Orders.Amount
FROM Orders

Figure 5-4: This simple SQL query follows basic SQL conventions.

SQL Items Automatically Generated by Crystal
Reports
When you view the SQL automatically generated by Crystal Reports based on Crystal Reports
commands specified by the user, the SQL may look different from SQL you may have created
yourself to achieve the same result. Crystal Reports may add several items to the automatically
generated SQL that are sometimes necessary, but that are not necessary in all cases.

SQL Conventions

SQL Items Automatically
Generated by Crystal Reports
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SQL Item Generated in
Crystal Reports

Reasons for Using This Compo-
nent Example

All field names may appear
preceded by the table name,
with a period separating the
table and field name.

This is useful to add clarity to
your SQL statements when you’re
accessing a database that includes
many tables, and is required when
you’re accessing a field whose
name matches another field name
used in a different table.

SELECT Contact.Name
FROM Contact

Field, table, and other object
names may be enclosed
within grave (′) or quotation
marks. The character gener-
ated by Microsoft Access
connections is a grave mark,
so you will see that in many
of the examples in this
course.

These special enclosing grave or
quotation marks are only required
when object names include spaces,
which is considered poor style in
database design, and so is rarely
used. The Crystal Reports genera-
tor adds these characters to all
fields and tables, whether or not
they use a space.

SELECT 'Income'.'1st
Qtr'
FROM 'Income'

In the FROM clause, the
table name appears twice.

The second instance of the table
name is actually an alias. Crystal
Reports automatically specifies an
alias name for all report tables,
which by default, matches the
name of the original table. An
alias is often created to provide a
shorter name that can be used
throughout the statement in place
of the original table name.

SELECT 'Contact'.'Name'
FROM 'Income' 'Income'

SQL Items Automatically
Generated by Crystal Reports
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Figure 5-5: Automatically generated SQL in Crystal Reports may include items that
aren’t always necessary.

How to Create a Report Using SQL Queries
Procedure Reference: Create a Report Using an SQL Command

To create a report based on an SQL query:

1. Choose File→New, and in the Crystal Reports Gallery dialog box, select As A
Blank Report, then click OK.

2. In the Database Expert dialog box, browse to the connection of your choice.

3. Expand the connection and double-click the Add Command option.

4. In the Add Command To Report dialog box, in the Enter The SQL Query In The
Box Below section, specify the SQL query, then click OK.

5. In the Field Explorer, expand the Database Fields item, then expand the Com-
mand item within it to display the fields retrieved from the database, as specified
by the SQL.

6. Drag the fields onto the report as desired.

Procedure Reference: Modify an SQL Command

To modify an SQL command:

1. Open the Database Expert dialog box.

2. In the Selected Tables column, right-click the Command item, and select Edit
Command.

3. In the Modify Command dialog box, make any changes to the SQL query, then
click OK to return to the Database Expert dialog box.
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4. Click OK.

Procedure Reference: View Automatically Generated SQL Queries

To view an SQL query automatically generated by Crystal Reports based on the com-
mands and options you specified:

1. Choose Database→Show SQL Query.

2. After viewing the SQL query in the dialog box, click OK.

ACTIVITY 5-1
Creating a Report Using an SQL Query

Scenario:
You want to generate a report that displays the name of each employment position in your
company’s sales department alphabetically, along with the Supervisor ID for the person who
oversees each position. You want to begin entering SQL manually to generate reports, but
aren’t sure that you could do so correctly.

What You Do How You Do It

1. Create the report without manually

specifying the SQL.

a. Open the Database Expert for a blank

new report.

b. Browse to and expand the C:\

085516Data\xtreme.mdb connection.

c. Add the Employee table to the report,

then click OK.

d. From the Field Explorer, drag the Posi-

tion and Supervisor ID fields to the

Details section.

e. Preview the report.

f. Using the Record Sort Expert dialog box,
sort the data by the Position field in

ascending order.
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2. View the SQL query created by

Crystal Reports to request the data.

a. Choose Database→Show SQL Query.

b. Click OK.

c. Close the report without saving it.

3. Create the report by manually

specifying an SQL query.

a. Open the Database Expert for a blank

new report.

b. Browse to and expand the C:\

085516Data\xtreme.mdb connection.

c. Double-click the Add Command item.

d. In the Add Command To Report dialog
box, type

SELECT Position, 'Supervisor ID'
FROM Employee
ORDER BY Position

e. Click OK.

f. In the Database Expert dialog box, click

OK.

g. In the Field Explorer, expand the Data-

base Fields and Command items, then

drag the Position and Supervisor ID

fields to the Details section.

h. Preview the report, and notice that the

data is already alphabetized by the Posi-

tion field, as specified by the SQL you

entered.

Be sure that your students
enclose the Supervisor ID field
name within ′ characters, since
it is a field name made up of
two words separated by a
space.

LESSON 5

Lesson 5: Enhancing Report Processing Using SQL 113



FO
R 

EV
AL

UA
TI

O
N 

US
E 

O
NL

Y

DO
 N

O
T 

DU
PL

IC
AT

E

(C
) 2

00
4

El
em

en
t K

Co
nt

en
t L

LC

4. This report includes several repetitions of the same Position field. How could you

modify the SQL to return only one instance of each position?

Modify the query to include the DISTINCT clause.

5. Modify the query so that it only lists

each position once.

a. Open the Database Expert dialog box.

b. In the Selected Tables list, right-click

Command, and select Edit Command.

c. Following the SELECT keyword, type DIS-
TINCT

d. Click OK.

e. In the Database Expert dialog box, click

OK.

6. Save and close the report. a. Save the report as Sales Positions

b. Close the report.
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TOPIC B
Summarize Report Data Using SQL
Aggregate Functions
When you create a report using SQL queries, you may want to summarize some of the report
data. In this topic, you will include aggregate functions within an SQL query to summarize
report data.

Imagine that you’re generating a report using an SQL query. You want to access the Position
field from the Employee table, and display the total number of employees in each position.
Using an SQL aggregate function causes the number of employees for each position to be cal-
culated on the remote server, which allows the grouped data to appear in a detail section.

Figure 5-6: You can use the COUNT aggregate function to summarize report data.

SQL Aggregate Functions
Definition:

An SQL aggregate function is a function that produces a single summary value for a
group of values in a specified field. You can use aggregate functions in two clauses:
the SELECT clause and the HAVING clause. Aggregates require an expression, which
is enclosed in parentheses. In general, aggregate functions appear as follows, where the
expression is typically a field name:

aggregate_function(expression)

An Example of an SQL
Aggregate Function
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Example:

Figure 5-7: This COUNT aggregate function will display the number of employ-
ees with a given position title in the company.

SQL Aggregate Function Descriptions

Function Description
AVG Calculates an average of values in a numeric field or expression.

COUNT Determines the number of records that match specified criteria.

MAX Determines the greatest value in a specified field or expression.

MIN Determines the smallest value in a specified field or expression.

SUM Calculates a total of values in a numeric field or expression.

Aggregate Functions with Grouped Data
An aggregate function that performs an operation on a group level cannot be used in a
simple SELECT clause without a corresponding GROUP BY clause.

How to Summarize Report Data Using SQL
Aggregate Functions
Procedure Reference:

To summarize report data using an SQL aggregate function:

1. In the Add Command To Report dialog box, in the SELECT clause, specify the
aggregate function keyword you want to use.

2. Within parentheses, specify the name of the field you want to summarize.

3. After the closing parenthesis, type AS, followed by the name you want to use for
the resulting summary field.

4. Specify any additional elements you want to include in the SQL query, then click
OK.

5. Drag the generated summary element from the Field Explorer onto the report
layout.

SQL Aggregate Function
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ACTIVITY 5-2
Summarizing Report Data Using the COUNT Function

Setup:
Crystal Reports is running and there are no files open.

Scenario:
You have been working with SQL and know how to create simple SQL statements. You have
been asked to create a simple report counting the number of customers you have in each
region.

What You Do How You Do It

1. Create a new, blank report, open-

ing the Add Command option for

the xtreme.mdb database file.

a. Choose File→New. Select As A Blank

Report and click OK.

b. In the Database Expert, browse to and

expand the xtreme.mdb.

The file will be located in the History folder if
you’ve done previous exercises.

c. Double-click the Add Command option.

2. Write an SQL statement that will

return a count of all customers in

each region, sorted by region.

a. Type the following in the Enter SQL

Query In The Box Below text box:

SELECT Region,
COUNT(Customer.'Customer ID') as
'Number of Customers'
FROM Customer
GROUP BY Region
ORDER BY Region

b. Click OK.

c. In the Database Expert, click OK.

Make sure that your students
do not type a single quote, but
type the grave ( ` ) accent
mark located on the upper-left
corner of the keyboard.
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3. Add the two fields from the query

to the Details section of the report.

a. In the Field Explorer, expand Database

Fields and expand Command.

b. Insert the fields labeled “Region” and

“Number of Customers” in the Details

section.

4. Preview and save your report as

Customer Count by Region.rpt.
a. Preview the report.

b. Save the report as Customer Count by
Region and then close it.

c. Close the report.
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TOPIC C
Create Joins Using SQL
As you generate reports using SQL queries, you’ll often need to include data from multiple
tables. In this topic, you will create joins using SQL queries, so that you can include data from
multiple tables in your reports.

Suppose you want to create a report that includes fields from both the Customer and Orders
tables. You plan to generate the report using SQL. You can specify a join using SQL so that all
the data you want will be available.

Figure 5-8: You can specify joins within your SQL queries.

Joins
Definition:

A join is a specification that links two or more tables together so that data from all the
linked tables can be used within a single report. You can only join tables that include a
field in common.

A Join Specified by SQL

LESSON 5

Lesson 5: Enhancing Report Processing Using SQL 119



FO
R 

EV
AL

UA
TI

O
N 

US
E 

O
NL

Y

DO
 N

O
T 

DU
PL

IC
AT

E

(C
) 2

00
4

El
em

en
t K

Co
nt

en
t L

LC

Example:
Suppose you want to use fields from both the Customer and Orders tables within a
single report, and you want to use an SQL query to generate the report. Both of these
tables include a Customer ID field, which you can use to join the tables. To include
the Customer Name field from the Customer table, along with the Order Date and
Order Amount fields from the Orders table, you could specify the query shown in Fig-
ure 5-9.

Figure 5-9: Specifying a join allows you to access data from multiple tables in
a single report.

SQL Join Types
There are several types of joins that you can specify within an SQL query. The join type you
use can limit or expand the records that will be included in the available set of data.

Join Type Description Example
Inner Join Accesses all the records in which

the linked field value in both tables
is an exact match.

SELECT Name, Amount
FROM Orders
INNER JOIN Customer
ON Orders.ID = Customer.ID
This query includes all records from each
table whose ID field has a corresponding
match in the other table.

Left Outer Join Accesses all records in which the
linked field value in both tables
matches, as well as all records from
the table whose name directly fol-
lows the FROM keyword within the
query, also known as the primary
table.

SELECT Name, Amount
FROM Orders
LEFT JOIN Customer
ON Orders.ID = Customer.ID
This query includes all records from each
table whose ID field has a corresponding
match in the other table, along with all
records from the Orders table.

Right Outer Join Accesses all records in which the
linked field value in both tables
matches, as well as all records from
the table whose name directly fol-
lows the JOIN keyword, also
known as the lookup table.

SELECT Name, Amount
FROM Orders
RIGHT JOIN Customer
ON Orders.ID = Customer.ID
This query includes all records from each
table whose ID field has a corresponding
match in the other table, along with all
records from the Customer table.

The Components of an SQL
Query that Specifies a Join

SQL Join Types
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Joins via the WHERE Clause
You may sometimes see joins specified within the WHERE clause, as in:

SELECT Name, Amount
FROM Customer, Orders
WHERE Customer.ID = Orders.ID

The preceding example would return the Name field from the Customer table, and the
Amount field from the Orders table. The two tables are joined via the ID field.

Join Conditions
This course focuses on comparing join values based on equality, but in most databases,
a comparison can be done using other comparison operators, such as < and >, as
shown in Figure 5-10.

Figure 5-10: The Link Options dialog box allows you to specify the type of
comparison operator used in specifying a join.

How to Create Joins Using SQL
Procedure Reference: Specify a Join in an SQL Query

To join tables using an SQL query:

1. In the Add Command To Report dialog box, in the SELECT clause, specify the
fields you want to include from each table, with commas separating each field
name.

2. In the FROM clause, specify the primary table.

3. Specify the JOIN keyword you want to use, followed by the name of the lookup
table.

4. Type the ON keyword, followed by the link field that links the two tables, using
the following format: primary table.link_field = lookup
table.link_field.

5. Drag the generated fields from the Field Explorer onto the report layout.
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Procedure Reference: Specify a Join Type Using Crystal Reports Commands

To specify a join type using the commands within Crystal Reports:

1. In the Database Expert dialog box, select the Links tab.

2. Select the links line that connects two tables.

3. Select the Link Options button.

4. In the Join Type section, specify the type of join you want to use, then click OK.

5. Click OK to close the Database Expert dialog box, and refresh data if necessary.

ACTIVITY 5-3
Creating SQL Joins

Scenario:
You need to create a report that lists the names of all employees, along with the country in
which they’re based. The employee name fields are in the Employee table, but the country data
is in the Employee Addresses table. Fortunately, each of those tables include the Employee ID
field.

What You Do How You Do It

1. Create a new, blank report, open-

ing the Add Command option for

the xtreme.mdb database file.

a. Choose File→New. Select As A Blank

Report and click OK.

b. In the Database Expert, browse to and

expand the xtreme.mdb database.

c. Double-click the Add Command option.
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2. Write an SQL statement that will

include the data you need, sorted

by country.

a. Type the following in the Enter SQL

Query In The Box Below text box:

SELECT 'First Name', 'Last Name',
'Country'
FROM Employee
INNER JOIN 'Employee Addresses'
ON Employee.'Employee ID'=
'Employee Addresses'.'Employee ID'
ORDER BY Country

b. Click OK.

c. In the Database Expert, click OK.

3. Add the fields to the report. a. In the Field Explorer, expand Database

Fields and expand Command.

b. Insert the First Name, Last Name, and

Country field in the Details section.
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4. Preview the report, and save it as

Employees by Country.
a. Preview the report.

b. Adjust the field positions and sizes as

necessary.

c. Save the report as Employees by Coun-
try

d. Close the report.

ACTIVITY 5-4
Changing the Join Type

Scenario:
One of your colleagues created a report titled Customer Credit Amounts.rpt. You want to
locate the credit data for a company named AIC Children.

What You Do How You Do It

1. View the Customer Credit

Amounts.rpt file.

a. In the Standard toolbar, click the Open

button.

b. Navigate to the 085516Data folder, and

open the Customer Credit Amounts.rpt

report.

c. Notice that there is no entry for the AIC

Children company.
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d. Choose Database→Show SQL Query.

2. As you view the SQL query, why do you think that the report doesn’t display an entry

for the AIC Children company?

This SQL query specifies an inner join, so only records that exist in both tables, with a
matching Customer Credit ID value will appear in the report. The AIC Children company
exists in the Customer table, but may not have a corresponding record in the Credit
table.

3. How could you modify the join so that all records from the Customer table were

included in the report?

Change the join type from an inner join to a left outer join.

Click OK.

4. How could you change the join type for this report?

The SQL query for this report was generated automatically by Crystal Reports, and was
not manually entered by the report’s creator. Therefore, rather than directly editing the
SQL query, you will use the Links tab in the Database Expert dialog box.
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5. Change the join type. a. Open the Database Expert dialog box,

then select the Links tab.

b. Select the links line that joins the two

tables.

c. Select Link Options.

d. In the Link Options dialog box, in the Join
Type section, select Left Outer Join,

then click OK.

e. In the Database Expert dialog box, click

OK, then click OK to refresh the report

data.

f. Notice that many additional records now

appear in the report, representing

records that existed in the Customer

table, but without a corresponding

record in the Credit table.
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6. View the updated SQL query. a. Choose Database→Show SQL Query.

b. Notice that the SQL query now specifies

a left outer join.

c. Click OK.

d. Save and close the report.

TOPIC D
Create Subqueries
As you create more complex reports using SQL queries, you may need to include subqueries.
In this topic, you will create subqueries within your queries.

Subqueries allow you to create complex queries that extract data not available through other
querying methods. For example, you may want to create a report that includes an aggregate
function to display the total count of orders, along with the Order Date and Order Amount
fields. Using the simple SELECT clause structures you’ve used in the past would not work to
produce the fields you wanted. However, a subquery would allow you to generate the desired
report data.

Figure 5-11: A subquery can produce results that may not be possible using a stan-
dard SELECT clause.
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Subqueries
Definition:

A subquery is a second SELECT clause that is nested inside an outer query. You can
use a subquery within the SELECT, FROM, WHERE, or HAVING clauses. Subqueries
must be enclosed in parentheses.

Example:

Figure 5-12: This query includes a subquery that specifies the average order
amount.

How to Create Subqueries
Procedure Reference:

To create subqueries within your SQL queries:

1. In the Add Command To Report dialog box, specify the SQL query you want to
use.

2. Within parentheses, specify the subquery you want to use.

3. Drag the generated fields from the Field Explorer onto the report layout.

An SQL Subquery
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ACTIVITY 5-5
Creating Subqueries

Scenario:
You have a report named Latest Orders.rpt, which lists the most recent order date for each
customer. You want to ensure that the database server is processing the report data, and send-
ing only the necessary data to your computer.

What You Do How You Do It

1. Determine whether the SQL server

is designated to process all the

data.

a. Open the Latest Orders.rpt file.

b. Display the Select Expert, and select

Show Formula.

c. Notice that the formula is a group selec-

tion formula, limiting the records based

on an aggregate calculation on the Cus-

tomer Name group.

d. Close the Select Expert.

e. Choose Database→Show SQL Query.

f. Notice that the SQL query automatically

generated by Crystal Reports pulls down

all records, causing Crystal Reports to

perform the processing that limits the

records based on the formula you

viewed in the Select Expert.

g. Click OK, then close the file.

2. Create a new report that generates

the same data, but uses an SQL

query to specify that the processing

occur on the remote server.

a. Choose File→New. Select As A Blank

Report and click OK.

b. In the Database Expert, browse to and

expand the xtreme.mdb database.

c. Double-click the Add Command option.
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d. Type the following in the Enter SQL

Query In The Box Below text box:

SELECT 'Customer Name',

(SELECT Max('Order Date') FROM
Orders WHERE Orders.'Customer
ID' = Customer.'Customer ID') AS
LastOrder

FROM Customer
ORDER BY 'Customer Name'

e. Click OK.

f. In the Database Expert, click OK.

3. Add the fields to the report. a. Add the Customer Name and Last Order

fields to the report.

b. Preview the report.

4. Save and close the report. a. Save the report as Latest Orders

Revised.rpt.

b. Close the report.
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TOPIC E
Create an SQL Expression Field to
Promote Server-side Processing
Another way to process data more efficiently in your reports using SQL is to create SQL
expression fields. In this topic, you will create and use SQL expression fields to enhance the
ability of your report to select, sort, and group report data on the database server.

SQL expressions you create can often improve your report’s performance, since the tasks they
specify are typically performed by the database server, rather than on your computer. On the
other hand, regular formulas you create in Crystal Reports are often performed on your com-
puter, rather than on the database server, slowing performance.

Figure 5-13: The Salary field was created as an SQL expression field.

SQL Expression Fields
Definition:

An SQL expression field is a formula written in SQL rather than in the Crystal Reports
formula language, which you can use to sort, group, and select data. SQL expressions
are typically implemented on the SQL database server, which frees up your computer’s
resources for other tasks. SQL expressions will almost always increase your report effi-
ciency, but the options available are limited. You will find there is much more
flexibility offered by the functions and operators available in the Crystal Reports for-
mula language, both Crystal Syntax and Basic Syntax.

An SQL Expression Field
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Example:

Figure 5-14: You can create SQL expression fields within the Formula
Workshop.

How to Create an SQL Expression Field to Promote
Server-side Processing
Procedure Reference: Enable Server-side Processing

To enable server-side processing:

1. Choose File→Report Options to display the Report Options dialog box.

2. Check the Perform Grouping on Server check box.

3. Click OK.

Procedure Reference: Create an SQL Expression Field

To create an SQL expression field:

1. On the Field Explorer, select SQL Expression Fields and click the New button.

2. In the SQL Expression Name box, type a name for the SQL expression and click
OK to display the SQL Expression Editor.

3. Type the expression in the SQL Expression Editor.

4. Click OK to close the SQL Expression Editor dialog box.

Procedure Reference: Select Records Using an SQL Expression

To select records using an SQL expression field:

1. Display the Select Expert dialog box.

2. If necessary, delete the current field selection.

3. Click the New tab to display the Choose Field dialog box.
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4. From the Fields list box, select the SQL expression and click OK. An SQL
expression appears in the Fields tree with a % prefix.

5. Use the drop-down list to enter your selection criteria for the indicated field.

6. Click OK to generate the selection formula based on your specifications, limiting
the report to the records you indicated.

ACTIVITY 5-6
Selecting Data Using SQL Expression Fields

Data Files:

• 2002 Canada Sales.rpt

Setup:
No data files are open.

Scenario:
The 2002 Canada Sales.rpt report summarizes 2002 sales. Although the report runs fine now,
you anticipate that as the amount of data displayed by the report increases, it will take several
minutes to run. You have been asked to speed the processing of this report. You want the fil-
tering of the data to be done on the network server.

What You Do How You Do It

1. In 2002 Canada Sales.rpt, view the

selection formula.

a. Open 2002 Canada Sales.rpt and click

the Select Expert button .

b. Click Show Formula.

2. How many filters are in the formula and what are they?

There are two filters: Country = Canada and Order Date = 2002. In other words, records
are selected based on the country Canada only and the Order Date is set to 2002.

3. Close the Select Expert dialog box

and open the Show SQL Query dia-

log box to view the query.

a. On the Select Expert dialog box, click the

Close button.
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b. Choose Database→Show SQL Query.

4. What is the selection criteria limiting?

The selection criteria limits the country to Canada as shown in the WHERE clause. The
criteria for the order date (Year = 2002) does not appear.

5. How could you fix this?

By building an SQL expression that allows the filtering to be done at the server level.

6. Build an SQL expression called

YearFilter that will represent the

year of the order date field

enabling filtering to be done at the

server level.

a. Close the Show SQL Query dialog box.

b. In the Field Explorer, select SQL Expres-

sion Fields and click New.

c. Type YearFilter and click OK.

d. In the SQL Expression Editor window,
expand the Functions tree for the Date/

Time category.

e. Within the Date/Time category, double-

click Year().

f. Notice that the insertion point is inside

the parentheses.
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g. In the Fields tree, expand the Orders

table and double-click the Orders.Order

Date field.

h. Check, save, and close the formula.

i. Save the report.

7. You will now delete the non-SQL
selection formula already in the
report. Select and delete the

Orders.Order Date formula.

a. Click the Select Expert button.

b. Select the Orders.Order Date tab and

click the Delete button.

8. Replace the %YearFilter formula on

a new tab that is equal to 2002 and

refresh the records.

a. Select the New tab.

b. From the Fields list, select the

%YearFilter SQL expression and click

OK.
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c. From the drop-down list, select Is Equal

To. In the next box, type 2002 and click

OK.

d. Click the Refresh Data button.

e. Notice that the same 37 records get

returned.

9. View the SQL Query to examine the

WHERE clause.

a. Choose Database→Show SQL Query.

b. If necessary, scroll down to view the

WHERE clause.

10. What has changed about the WHERE clause shown in the following graphic?

All the selection criteria is listed in the WHERE clause, including the year filter.

Click OK, then save and close the report.
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Lesson 5 Follow-up
You now know how to enhance your reports using SQL. The ability to incorporate SQL into
your reports will allow you and others to access report data quickly and efficiently, and to per-
form reporting functions not otherwise possible.

1. How could you incorporate SQL to enhance your own reports?

Answers will vary.

2. What did you learn in this lesson that will be most useful for you in your work?

Answers will vary.
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Charting Data

Lesson Objectives:
In this lesson, you will chart single and multiple data series.

You will:

• Create a bar chart.

• Modify a chart.

• Create a Top N chart.

• Format a chart.

• Create a template based on an existing chart.

Lesson Time
1 hour(s), 30 minutes to
2 hour(s)

LESSON 6
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Introduction
You already know how to create a pie chart with single data series. In this lesson, you’ll create
and modify a bar chart with multiple data series.

Imagine you had to review pages and pages of summary data to make comparisons of certain
products and identify trends. It would be much faster and easier to identify these results if they
were presented in a chart. With a quick glance on a color-coded one-page document you can
find the results you’re looking for quickly and easily.

TOPIC A
Create a Bar Chart
You’ve already learned how to create a pie chart that represents percentages for each item.
There will be times when you’ll need to create a chart that shows how each item compares to
each other in terms of volume, size, dollars, and so on. In this topic, you’ll create a bar chart.

Imagine you’re looking at a report that contains lots of information displayed in columns and
rows. You look at the report to try to identify which salesperson made the most sales. Now
imagine you’re looking at a bar chart and have to identify which salesperson made the most
sales. It’s much easier and faster to interpret the information and provide feedback when infor-
mation is presented in a chart as shown in Figure 6-1.

Figure 6-1: It is often easier to understand and analyze data when it is displayed as a
bar chart.

Displaying Data as a Bar Chart
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How to Create a Bar Chart
Procedure Reference:

To create a bar chart:

1. Choose Insert→Chart to display the Chart Expert dialog box.

2. On the Type tab, select Bar as the type of chart.

3. If you want to specify options that the Chart Expert typically specifies by default,
then uncheck the Automatically Set Chart Options check box. The Axes and
Options tabs then appear.

4. On the Data tab, select the placement of the chart and how often the chart will
appear on the report.

5. On the Options tab, select the type of labels that will appear (data points), the
legend placement, and the bar size.

6. On the Text tab, select and enter the titles, footnotes, and axis titles for the chart.

7. Click OK to close the Chart Expert dialog box.

ACTIVITY 6-1
Creating a Bar Chart

Data Files:

• Glove-Helmet Sales.rpt

Setup:
Crystal Reports is running and there are no files open.

Scenario:
You’re getting ready to go to the company’s weekly sales meeting and you have to show the
glove and helmet sales for the European division. The report you print out doesn’t have the
purpose of the data represented properly and it’s not easy to identify trends in sales. Rather
than present a boring and difficult-to-read report, you decide to create a chart based on the
data.
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What You Do How You Do It

1. In Glove-Helmet Sales.rpt, in Design
view, display the Chart Expert dia-

log box.

a. Open Glove-Helmet Sales.rpt and, if nec-
essary, change to Design view.

b. Choose Insert→Chart.
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2. Create a bar chart showing total

helmets sold by country.

a. On the Type tab, verify that Bar is

selected.

b. Uncheck Automatically Set Chart

Options.

c. On the Data tab, in the Layout box, verify

that Group is selected.

d. From the On Change Of drop-down list, if
necessary, select Customer.Country.

e. From the Show drop-down list, if neces-
sary, select Sum of @Helmets.

3. Make the bar size smaller than the

default setting, and display the

total helmets sold per country on

each of the bars.

a. Select the Options tab.

b. From the Bar Size drop-down list, select

Average.

c. In the Data Points box, select Show

Value.
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4. Title the chart “Helmets Sold Per

Country,” and title the Data

“Helmets.”

a. Select the Text tab.

b. Uncheck the Title box and type Helmets
Sold Per Country

c. Uncheck the Data Title box and type

Helmets

d. Click OK.

e. Preview the chart, then save it.

5. How many sets of data (data series) are displayed in this chart?

One. The data series being displayed is the total helmet sales per country. There are no
other data series shown in this chart.

If the chart displayed multiple sets of data, there would be additional bars representing
other totals.

TOPIC B
Modify a Chart
After creating a chart, you might want to make some changes to it. You might want to change
the chart from a pie chart to a bar chart, change the titles that appear on the chart, or change it
from an Advanced to a Grouped chart. In this topic, you will modify a chart.

As you already know from building several types of reports, you don’t often get the results
you want the first time. Luckily, Crystal Reports makes modifying reports quick and easy. The
same is true for charts. If you don’t like a chart’s initial results, you can quickly and easily
make changes to the chart data or its appearance.

A Bar Chart Changed to a Pie
Chart

LESSON 6

Crystal Reports 10.0: Level 2144



FO
R 

EV
AL

UA
TI

O
N 

US
E 

O
NL

Y

DO
 N

O
T 

DU
PL

IC
AT

E

(C
) 2

00
4

El
em

en
t K

Co
nt

en
t L

LC

Figure 6-2: You can modify many aspects of a chart, including the chart type.

How to Modify a Chart
Procedure Reference:

To modify a chart:

Options will vary depending on what you need modified.

1. Display the Chart Expert dialog box by right-clicking the chart and choosing
Chart Expert, or by selecting the chart, and choosing Format→Chart Expert.

• On the Type tab, you can change the type of chart.

• On the Data tab, you can change the placement of the chart and how often
the chart will appear on the report.

• On the Options tab, you can change the type of labels that will appear (data
points), the legend placement, and the bar size.

• On the Text tab, you can select and enter the titles, footnotes, and axis titles
for the chart.

2. Click OK to close the Chart Expert dialog box.

3. If you want to modify a specific component of a chart, select that component so
that it is individually selected, then right-click it and select the appropriate
command.
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ACTIVITY 6-2
Modifying a Chart

Setup:
Glove-Helmet Sales.rpt is open in preview.

Scenario:
You have a chart that shows one set of data (helmet sales). You have been asked to add the
glove sales data to the same chart. When you’re finished, your chart should look like Figure
6-3.

Figure 6-3: The chart after modifying.

What You Do How You Do It

1. In the Chart Expert, display the Data

tab.

a. Right-click the chart and choose Chart

Expert.

b. Select the Data tab.

2. Change the chart to display total

gloves and total helmets sold by

country.

a. In the Layout box, select Advanced.

b. In the Available Fields list box, select

Customer.Country and click the Add but-

ton next to the On Change Of list.

c. In the Available Fields list box, select

Gloves and click the Add button next to

the Show Value(s) box.

d. In the Available Fields list box, select Hel-

mets and click the Add button next to

the Show Value(s) box.
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3. Remove the title for data points and

move the chart legend to the

bottom.

a. On the Options tab, in the Data Points
box, verify that the Show Label check

box is unchecked.

b. In the Placement drop-down list, select

Bottom.

4. Make the change to the title to add

the words “and Gloves.”

a. On the Text tab, change the title to add

the words and Gloves

b. If necessary, remove any text specified

for the Data title.

c. Click OK.

5. Preview the chart. How has the chart changed?

The chart now displays multiple data series: helmets and gloves.
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6. Change the Legend headings to

read Gloves and Helmets
a. In the Legend, click the Sum of @Gloves

label so that a selection border appears

around it.

b. Right-click the selected label, and select

Edit Axis Label.

c. In the Displayed Label field, type Gloves

d. Click OK.

e. Change the other Legend label to Hel-
mets

f. Save and close the report.

TOPIC C
Create a Top N Chart
When creating a chart to graphically display data, you may sometimes want the chart to only
represent a portion of data. In this topic, you’ll create a Top N chart to display only a subset
of the available data.

At times you might want to show only the “top” or “bottom” producers in a chart. For
example, you could show the fastest selling product lines, the least productive sales regions, or
the states that generate the most orders.

A Top N Chart
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Figure 6-4: A Top N was used to display only the top three salespeople.

How to Create a Top N Chart
Procedure Reference:

To create a Top N chart:

1. Display the Chart Expert.

2. On the Data tab, select the field you want and click the TopN button to display
the Group Sort Expert dialog box.

3. In the For This Group Sort list box, select TopN.

4. Select the summary field that the chart will be based on.

5. Enter the number that you want to represent as N (where N is the number of
values).

6. Click OK to return to the Chart Expert.

7. Click OK to close the Chart Expert and create the TopN chart.
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ACTIVITY 6-3
Creating a Top N Chart

Data Files:

• Sales by Country.rpt

Setup:
There are no files open.

Scenario:
You have a bar chart that displays sales of helmets in five countries: Australia, Canada,
England, Germany, and the USA. You want to see the top three regions within each country.
You also want to display the data as currency.

What You Do How You Do It

1. In Sales by Country.rpt, copy the bar

chart from the report header into

the country group footer.

a. In Sales by Country.rpt, in Design view,
right-click the chart in the report

header and choose Copy.

b. Right-click in the Group Footer section

and choose Paste.

c. The mouse pointer is holding the chart. In
the upper-left corner of the Group Footer,
click the mouse button to position the

chart.

2. On the chart located in the Group
Footer, change the data series to

group by region rather than by

country.

a. Right-click the chart in the Group Footer

and choose Chart Expert.

b. On the Data tab, below the On Change Of
drop-down list, select

Customer.Country-A and click the

Remove button.
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c. In the Available Fields list box, select

Customer.Region and click the Add

button.

3. Display the top three customers in

each region.

a. Below the On Change Of field, select

Customer.Region-A.

b. Click the TopN button.

c. From the For This Group Sort drop-down
list, select Top N.

d. From the Based On drop-down list, if nec-
essary, select Sum of Customer.Last

Year’s Sales.

e. In the Where N Is box, type 3

f. Verify that the Include Others, With The

Name option is unchecked.

g. Click OK.

4. Display the data points as dollars. a. On the Options tab, in the Data Points
box, select Show Value.
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b. Set the Number format to $1.00.

5. Change the title to Top Three
Regions

a. On the Text tab, select the title text and

type Top Three Regions

b. Click OK.

6. Preview the chart. How has the chart changed?

There are five charts showing the top three regions in each country.

Save and close the report.

TOPIC D
Format a Chart
Once you’ve created and modified a chart, you might want to change its appearance. In this
topic, you’ll change a chart’s formatting.

Charts are great at displaying complicated data graphically, which makes interpreting data
quick and easy. However, if the data labels are illegible, or the default color selections are
incompatible, you have a problem. To solve this problem and make your charts more visually
appealing, you can format individual chart components. Chart formatting options enable you to
change colors, sizes, presentation view, grid options, axis scales, and more.

A Chart with Modified
Formatting
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Figure 6-5: One way to adjust a chart’s formatting is to change its colors.

Chart Formatting Options
The following table identifies the format options that are available in the Chart Options
submenu:

Chart Format Option Description
Template Displays the Choose A Chart Type dialog box to enable you

to select a chart template from the Gallery tab or create your
own custom chart template from the Custom tab.

General Displays the Chart Options dialog box to enable you to
change the General, Layout, Data Labels, Numbers, Look,
and Display Status options.

Titles Displays the Titles dialog box to enable you to change the
Title, Subtitle, Footnote, Group Title, and Data Axis titles.

Grid Displays the Numeric Axis Grids & Scales dialog box to
enable you to change the General, Scales, Labels, Numbers,
and Grids options on the Data Axis tab and change the Gen-
eral, Labels, and Grids options on the Group Axis tab.

Selected Item Provides formatting options specific to the selected chart
item.

Chart Formatting Options
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How to Format a Chart
Procedure Reference:

To format a chart:

1. Right-click the chart and choose Chart Options, or select the chart and choose
Chart→Chart Options, to display the Chart Options submenu.

• Choose Template to display the Choose A Chart Type dialog box to apply or
customize a template.

• Choose General to display the Chart Options dialog box to change the Gen-
eral, Layout, Data Labels, Numbers, Look, and Display Status options.

• Choose Titles to display the Titles dialog box to change the Title, Subtitle,
Footnote, Group Title, and Data Axis Title.

• Choose Grid to display the Numeric Axis Grids & Scales dialog box to
change the Data Axis and Group Axis options.

2. Click OK to close the dialog box and apply the changes to the chart.

3. If a chart repeats throughout a report to display data for each set of grouped data,
and you want to format one of the charts without impacting the others, then
modify it on the Preview tab.

4. If you want to update all charts based on formatting changes you made to a single
chart, then right-click the formatted chart and select Apply Changes To All Charts.

ACTIVITY 6-4
Formatting a Chart

Data Files:

• Regional Sales.rpt

Setup:
There are no files open.

Scenario:
You’re getting ready to hand in your report but find that it doesn’t look the way you want it
to. You decide that the data labels would look better if they were placed at the base of the
chart and that the blue data series should be purple because that color looks better when trans-
ferred to overheads that will be included in each report. When you’re finished, your chart
should look like Figure 6-6.
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Figure 6-6: The chart after you make changes to the chart options.

What You Do How You Do It

1. In Regional Sales.rpt, move the data

labels for the Region chart to the

base of the chart.

a. In Regional Sales.rpt, in Preview, right-

click one of the Top Three Regions

charts and choose Chart Options→
General.

b. Select the Data Labels tab and, from the
Labels Location drop-down list, select

Base Of Chart.

c. Verify that Label Format is set to Value.

d. Click OK.
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2. Make the data labels bold and

change the blue data series to

purple.

a. On the Region chart, select a data label

and right-click the data label.

b. Choose Chart Options→Selected Item.

c. In the Style drop-down list, select Bold.

d. In the Size drop-down list, select 10.

e. Click OK.

f. Click the blue data series to select it.

g. Right-click the blue data series to dis-

play the shortcut menu and choose

Chart Options→Selected Item to display

the Formatting dialog box.

LESSON 6

Crystal Reports 10.0: Level 2156



FO
R 

EV
AL

UA
TI

O
N 

US
E 

O
NL

Y

DO
 N

O
T 

DU
PL

IC
AT

E

(C
) 2

00
4

El
em

en
t K

Co
nt

en
t L

LC

h. Select purple (R6, C13) and click OK to

change the blue series to purple.

3. Preview the charts. How have the charts changed?

The changes were only made to the one chart.

4. Apply the changes to all charts and

preview the charts.

a. Right-click the chart and choose Apply

Changes To All Charts.

b. In Preview View, scroll to view all the

charts.

c. Notice that all of the region charts are

updated to purple.

d. Save and close the report.

TOPIC E
Create a Chart Template
Once you’ve formatted a chart, you may want to then create a template based on that chart. In
this topic, you’ll save a chart format as a template.

Let’s say that you’ve created and formatted several beautiful charts and distributed them to
your client. The client is so happy about the charts that she has given you some more work to
do and wants the charts to look just like the ones you created earlier. You could probably
duplicate the appearance of the charts but it’s going to take some time. Imagine the time you
could save if the chart settings were saved as a template.

A Chart Formatted Based on a
Template
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Figure 6-7: You can quickly apply a set of desired chart formatting options using a
template.

Template
Definition:

A template is a set of chart formatting options that can be used as the starting point for
formatting a new chart, or applied to an existing chart. If you have a specific set of
chart settings you would like to use again and again, you can save them as a chart
template. You can then apply the chart settings to a chart that you create or edit.
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Example:

Figure 6-8: You can apply existing templates to your charts, or create your
own templates.

How to Create a Chart Template
Procedure Reference: Create a Chart Template

To save an existing chart as a template:

1. Make the changes to the chart that you want to save.

2. Right-click the chart and choose Save As Template, or select the chart and choose
Chart→Save As Template.

3. Type a name for your chart template and click Save. The template has been saved
under User Defined in the Templates dialog box. User Defined chart templates are
saved in the user defined template folder. By default, this folder is located at
\Program Files\Common Files\Crystal Decisions\2.5\ChartSupport\Templates\User
Defined. The only way to delete a user defined template is through Windows
Explorer.

Procedure Reference: Apply a Chart Template

To apply a chart template to another chart:

1. Right-click the unformatted chart, and select Chart Options→Template.

2. Select the Custom tab, and in the Categories box, select User Defined.

3. Select the template, then click OK.

Templates are Accessible in
the Choose A Chart Type
Dialog Box
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ACTIVITY 6-5
Creating a Chart Template

Data Files:

• Sales Report by Region.rpt

Setup:
No files are open.

Scenario:
You have spent considerable time with a co-worker determining the format options for a chart.
You want to incorporate the same formatting on all future financial reports.

What You Do How You Do It

1. In Sales Report by Region.rpt, save

the formatting from the Last Years

Sales by Country chart as a

template.

a. In Sales Report by Region.rpt, on the Last
Years Sales by Country chart, right-click

the chart and select Save As Template.

b. Name the template Financial Charts and

click Save.
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2. Apply the new template to the

chart in the Group Footer.

a. On the Design tab, view the chart in the

group footer.

b. In the chart in the group footer, right-

click and choose Chart Options→
Template.

c. On the Custom tab, in the Categories box,
select User Defined.

d. If necessary, select the template, then

click OK.

e. Preview the report.

3. What happened to the rest of the charts?

They were automatically updated.

Save and close the report.

Lesson 6 Follow-up
You’ve worked with charting data to create both single and multiple data charts. The ability to
create charts allows you to display data in a graphical format, making it easier to review and
make sense of your data at a glance.

1. What do you think are some advantages to using charts?

Answers will vary.

2. Will you use charts in your reports? How?

Answers will vary.

Be sure that your students are
in Design view when they
apply the template. If they
apply the template to a chart
on the Preview tab, it will
apply only to that instance of
the chart, rather than to the
chart for each set of grouped
data.
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Reporting on Excel Data

Lesson Objectives:
In this lesson, you will report from Excel data.

You will:

• Create a report based on Excel data.

• Modify a report.

• Update the report.

Lesson Time
1 hour(s) to 1 hour(s),
30 minutes

LESSON 7
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Introduction
You already know that Crystal Reports can generate reports based on data from many different
database sources. But what if you had Excel data that needed to be imported? In this lesson,
you’ll learn how to use data in your Excel spreadsheet to create a report while you are work-
ing directly within Excel.

Imagine you’re working along in your Excel spreadsheet that contains hundreds of rows and
columns and you think to yourself that this information would make more sense if it were dis-
played in a Crystal Reports report. The last thing you want to do is convert data. Fortunately,
you don’t have to. You can highlight a range of cells in the Excel spreadsheet and launch a
Crystal Report Wizard.

TOPIC A
Create a Report Based on Excel Data
At some point, you might have access to data in an Excel database that you think would be
useful in a Crystal Reports report. Crystal Reports makes it possible to use your Excel spread-
sheet as your data source. In this topic, you’ll build a report based on an Excel spreadsheet.

You’re probably familiar with pulling data from several different types of databases. One
source you might have overlooked is Excel. The ability to create reports based on your exist-
ing Excel files saves you time, because you don’t have to re-enter data, and you can generate
your report while you’re working in the Excel application.

A Report Based on Excel Data
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Figure 7-1: You can convert an Excel spreadsheet directly to a Crystal Reports report.

Set Up the Data Source
Before you use your Excel data for your Crystal Reports report, you need to make sure the
data is entered properly in the spreadsheet so that it can be used flawlessly in Crystal Reports.
Use the following list as a means of checking the data in the spreadsheet before you use it in
Crystal Reports.

Before you use Excel as the data source, make sure:

• The data is in simple column/field format.

• There is one row for column headings and all subsequent rows show field data only.

• There are no merged cells.

• There are no subtotals.

• There are no entirely blank rows or columns in the data.

A limitation of the Excel Crystal Add-on tool is that the Excel data file cannot be moved. If the file is moved, the
report will not be usable. The “set location” feature does not work reliably with Excel data files.

How to Create a Report Based on Excel Data
Procedure Reference:

To create a report based on Excel data:
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When you create a file from Excel data, the title you assign to your report will get stored in the Sum-
mary Information property box. If the file name is later changed, the original title will appear in the
upper-left corner of the screen rather than the file name. This can be changed by removing the infor-
mation stored in the File→Summary Information menu option.

1. In Excel, click the Crystal Reports Wizard button to open the Crystal Reports
Wizard.

2. Select the range of data including column headings.

• Drag to select the range of data to include.

• Click any cell within the data range, then click the Expand button to select
the entire range.

3. Click the Create Crystal Report button to open the Crystal Reports Wizard.

4. Add the fields to the Fields To Display list box, then click Next.

5. If desired, add any fields you want to group in the Group By list, then click Next.

6. If desired, add the fields you want to total in the Summarized Fields list, then
click Next.

7. If desired, set the selection criteria, then click Next.

8. If desired, select a style and enter a title and location for your report, then click
Next.

9. Specify how you want to save and view the report.

10. Click Finish to preview the report.

ACTIVITY 7-1
Creating a Report Based on Excel Data

Data Files:

• Personnel.xls

Scenario:
You have some employee information stored in an Excel spreadsheet that you want to display
as a report. The spreadsheet is named Personnel.xls. When you’re finished, your report should
look like Figure 7-2.
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Figure 7-2: The report after it’s generated from Excel.

What You Do How You Do It

1. In Personnel.xls, start the Crystal

Reports Wizard and select the

entire worksheet data.

a. Start Excel and open Personnel.xls.

b. Click the Crystal Reports Wizard button.

c. Click any cell in the range that contains

the data you would like to display in the

report.
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d. Click the Expand button to expand the

selected range automatically.

e. Click the Create Crystal Report button to

open the Crystal Reports Wizard to

choose the information to display on the

report.

2. Add the Emp ID, Last Name, First

Name, City, State, Phone, and Hire

Date fields to the report.

a. In the Available Fields list box, double-

click Emp ID to add it to the Fields To

Display list box.

b. Double-click Last Name, First Name,

City, State, Phone, and Hire Date to add

them to the Fields To Display list box.

3. Continue through the wizard nam-

ing the report Benefit
Enrollment.rpt.

a. Click Next four times to reach the Save

panel of the wizard.

b. Browse to locate the 085516Data folder.

c. In the File Name text box, type Benefit
Enrollment and click Save.

d. Click Finish.

4. In the maximized Preview window,
view the completed report at 100%

zoom.

a. Maximize the Preview window.

b. If necessary, in the Preview window,
change the zoom to 100%.

5. False True or False? You can adjust the size and position of fields in this Preview

window.

6. Close the Preview window, exit

Excel, and open the file from within

Crystal Reports.

a. Close the Preview window and exit

Excel.

b. If necessary, start Crystal Reports and

open Benefit Enrollment.rpt.
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7. Preview the report and increase

the Zoom to 100%.

a. Preview the report.

b. Change the Zoom Control to 100%.

8. What needs to be fixed in the report?

The size and position of some fields are too small or too large, the Hire Date field is set
to date/time format, and the names are in no particular order.

TOPIC B
Modify a Report Generated from
Excel Data
After you create a report based on Excel data, you’re ready to make some changes to the
report. In this topic, you’ll use Crystal Reports to modify a report based on Excel data.

When you need to make changes to the report that is based on Excel data, do you modify the
Crystal Reports report? What about keeping your data in Excel current? If you need to modify
the Excel data to add, delete, or edit, information, you make your changes in Excel and then
update your report in Crystal Reports. In this case, you only have to change a data source once
which is a helpful timesaver.

Figure 7-3: You may need to modify a report generated from Excel data.

A Report Based on Excel Data
that Contains too Much White
Space

LESSON 7

Lesson 7: Reporting on Excel Data 169



FO
R 

EV
AL

UA
TI

O
N 

US
E 

O
NL

Y

DO
 N

O
T 

DU
PL

IC
AT

E

(C
) 2

00
4

El
em

en
t K

Co
nt

en
t L

LC

How to Modify a Report Generated from Excel
Data
Procedure Reference:

To modify a report based on Excel data:

Options will vary depending upon the report needs.

1. In Crystal Reports, resize and reposition fields so the data is visible.

2. If necessary, change the format of any date fields.

3. Sort the report data as desired.

4. Save the report.

ACTIVITY 7-2
Modifying a Report Based on Excel Data

Setup:
Benefit Enrollment.rpt is open.

Scenario:
Your report needs some changes. It’s not in alphabetical order, some of the fields are too large,
and not all of the data is visible. When you’re finished, it should look like Figure 7-4.

Figure 7-4: The report after it’s modified.
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What You Do How You Do It

1. What is wrong with the size and position of the fields and the hire date field?

The hire date field is cut off. Most of the fields can be made smaller and moved to the
left to accommodate the hire date field.

2. How can you efficiently resize the fields so that each one is just large enough to dis-

play its contents?

Resize the fields on the Preview tab so you can see the data as you resize the fields.

3. Resize and reposition fields so that

all the fields and all the data are

visible.

a. On the Preview tab, resize the Emp ID,

Last Name, First Name, City, State, and

Phone fields so that each field is just

large enough to display its contents.

b. Move the fields to the left to make room

for the Hire Date field.

c. Expand the size of the Hire Date field

until all the data is visible.

4. What is wrong with the format of the Hire Date field?

It includes a date and time format.

5. Change the Hire Date format from

date/time to mm/dd/yy and then

decrease the size of the Hire Date

field.

a. Right-click the Hire Date field and

choose Format Field.

b. On the Date and Time tab, in the Style
list, choose 3/1/99 and click OK.

c. Adjust the Hire Date field size as

necessary.
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6. Sort the list by last name then first

name, in ascending order.

a. Click the Record Sort Expert button.

b. Add the Last Name and First Name fields

to the Sort Fields list box.

c. Verify that Sort Direction is set to

Ascending.

d. Click OK.

e. Preview the report.

7. Apply bold formatting to the field

labels.

a. In Design view, right-click the gray area

of the Page Header section, and choose

Select All Section Objects.

b. In the Formatting toolbar, click the Bold

button.

c. Preview the report.

d. Save the report.

TOPIC C
Update Data in a Report Based on
Excel Data
After you have created a report from Excel data and then made changes to the appearance of
the report in Crystal Reports, you may need to update the spreadsheet data. In this topic, you’ll
make changes to the report in Excel and then update the report in Crystal Reports.

At times, the Excel data upon which a report is based may change. This is especially true
when you’re working with employee information. New employees will be added and employ-
ees’ names or addresses will change. You don’t want to have to update this information in two
places. Instead, you would like to make the modifications to your Excel data and then update
the report in Crystal Reports.

Updating a Report when the
Excel Data on Which it is

Based has Changed
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Figure 7-5: You can update the data in a report that is based on an Excel
spreadsheet.

How to Update Data in a Report Based on Excel
Data
Procedure Reference:

To update the report data:

1. Exit Crystal Reports.

2. Start Excel and open the spreadsheet.

3. Make changes to the data in the spreadsheet (as necessary).

• Add rows or columns of new data

• Modify existing data (replace text)

• Delete rows or columns of data

4. Save the spreadsheet and Exit Excel.

5. In Crystal Reports, open the report and choose Report→Refresh Report Data (or
press F5) and click OK to refresh the report.

ACTIVITY 7-3
Updating the Report in Crystal Reports

Setup:
Benefit Enrollment is open.

Scenario:
Two new employees have joined the company, and another employee was married. You need
to modify the file in Excel and then update the report in Crystal Reports. When you’re fin-
ished, your report should look like Figure 7-6.
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Figure 7-6: The report after it’s been updated in Excel.

What You Do How You Do It

1. Exit Crystal Reports, and display

Personnel.xls.

a. In Crystal Reports, close the report.

b. Exit Crystal Reports.

c. Start Excel and open Personnel.xls.

2. Change Jacqueline Anderson’s last

name to Smith.
a. Click the cell that contains the last name

Anderson.

b. On the Formula bar, place the insertion

point at the end of the word Anderson.

c. Backspace to erase the word Anderson.

d. Type Smith

LESSON 7
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3. Add the following employee to the

end of the spreadsheet:

a. Click the last row and type EN1-55 and

press Tab.

b. Enter the last name Donahue

c. Enter the first name John

d. Enter the address 5 Main Street

e. Enter the city Victor

f. Enter the state NY

g. Enter the ZIP Code 14514-3309

h. Enter the phone number (315) 555-3422

i. Enter the hire date 3/2/99

4. Add the following employee to the

middle of the spreadsheet:

a. Place the insertion point in the middle

of the spreadsheet and choose Insert→
Rows.

b. Click the first cell in the blank row, and

type EN1-29 and press Tab.

c. Enter the last name Davis

d. Enter the first name Jane

e. Enter the address 4 Main Street

f. Enter the city Victor

g. Enter the state NY

h. Enter the ZIP Code 14514-3309

i. Enter the phone number (315) 555-9898

j. Enter the hire date 2/16/98

5. Save the spreadsheet and exit

Excel.

a. Choose File→Save.

b. Choose File→Exit.
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6. Reopen the Benefit Enrollment

report in Crystal Reports and

refresh the data.

a. Start Crystal Reports and open Benefit

Enrollment.

b. Choose Report→Refresh Report Data.

c. Click OK.

7. How has the updated data changed?

Jacqueline Smith’s name has been changed. The range being reported was expanded to
include the employee Jane Davis inserted into the middle of the report. However, the
employee John Donahue, who was added to the end of the report, outside the original
range, was not included.

Save and close the report.

Lesson 7 Follow-up
You now know how to create, modify, and update Crystal Reports from right inside your Excel
spreadsheet. Not only will this skill save you time doing your job, it will also give you another
source for data and information processing.

1. What kinds of reports do you think you’ll create with your Excel spreadsheet data?

Answers will vary.

2. What do you like about using Excel data to build reports? What do you dislike?

Answers will vary.
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Follow-up
You now know how to create complex reports and data sources using Crystal Reports’ tools so
that you can tap into the power of your company’s information.

1. Of the tools covered in this course, which one(s) will you use the most? Which one(s)

will you use the least?

Answers will vary.

2. What do you feel is the biggest advantage of using Crystal Reports? Why? What is the

biggest disadvantage? Why?

Answers will vary.

3. Of the tools covered in this course, which one did you like the most? Why? Which one

did you like the least? Why?

Answers will vary.

What’s Next?
This course is the last in the series. If you’re not working with direct PC database connections,
you might want to take courses related to Fundamentals of Querying, Advanced Querying, and
Relational Database Design.
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Inserting a Geographic Map

Objectives:
In this lesson, you will insert a geographic map.

You will:

• Insert a geographic map into a report.

Lesson Time
1 hour(s) to 1 hour(s),
30 minutes

APPENDIX A
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Introduction
At times, you’ll find that the report information you want to present is most effective when
presented graphically. You know this is true based on your experience with creating and modi-
fying charts. In this Appendix, you’ll learn how to use geographic maps to enhance the data in
your report.

Imagine that you had some complex geographical data and needed a simple way to present it.
For example, let’s say you wanted to show the highest sales by region. Currently this informa-
tion is displayed in a chart. To have even greater impact, you could present the information as
a map, highlighting or color coding the countries with the highest sales. This makes interpret-
ing large amounts of data quick and easy.

Figure A-1: This map indicates the level of sales from each country.

TOPIC A
Insert a Map
You’ve already learned how to use a pie and bar chart to help present your data. What if you
had data that represented a particular region or country? Wouldn’t a map make more sense to
the viewers of the report? In this Appendix, you’ll insert a geographic map into your report.

Let’s say you have a long report showing sales data regarding several products from different
regions. Trying to interpret all this data could be confusing and time consuming. If you dis-
played the products as colors on a map of the regions, you could analyze the information more
quickly and easily.

A Geographic Map Based on
Report Data

APPENDIX A

Crystal Reports 10.0: Level 2180



FO
R 

EV
AL

UA
TI

O
N 

US
E 

O
NL

Y

DO
 N

O
T 

DU
PL

IC
AT

E

(C
) 2

00
4

El
em

en
t K

Co
nt

en
t L

LC

How to Insert a Map
Procedure Reference:

To create a map:

1. Choose Insert→Map to display the Map Expert dialog box.

2. On the Data tab, in the Layout section, select the layout of the map depending on
the data you wish to map.

• Select the Advanced option view when you have multiple map values. You
determine which fields are used such as the On change of value, and the map
value. You can also set summary options.

• Select the Group option view if you have at least one group and at least one
summary field in your report.

• Select the Cross-tab layout button when mapping on a cross-tab object.

• Select the OLAP view option to map to an OLAP object.

3. On the Type tab, specify the type of map, as well as color and interval options to
apply to the mapped data.

4. On the Text tab, specify a map title and legend options.

ACTIVITY A-1
Inserting a Geographic Map

Scenario:
Xtreme Bicycle sells products internationally, and you have been asked to create a geographic
map that shows the customer density by country. You decide to use six different colors show-
ing the number of customers in the countries (with white being the lowest and red being the
highest.) The darker the color, the more customers in that country. Figure A-2 shows an
example of the completed map.

Figure A-2: The completed map with the Tooltip displaying the number of customers.

APPENDIX A

Appendix A: Inserting a Geographic Map 181



FO
R 

EV
AL

UA
TI

O
N 

US
E 

O
NL

Y

DO
 N

O
T 

DU
PL

IC
AT

E

(C
) 2

00
4

El
em

en
t K

Co
nt

en
t L

LC

What You Do How You Do It

1. Create a new report based on

xtreme.mdb using the Customer

table.

a. Click the New button and choose As A

Blank Report and click OK.

b. In the Available Data Sources list, expand

the Current Connections folder and

expand the C:\085516Data\xtreme.mdb

folder.

If this Appendix is not keyed on the same day
as the rest of the course, then you will expand
the History folder in step 1b, instead of the
Current Connections folder.

c. Expand Tables and add the Customer

table.

d. Click OK.

2. You want the countries in the map to
change colors based on customer
counts within each country. Insert a

map based on the selections from

the Data tab shown in the following

graphic.

a. Choose Insert→Map.

b. On the Data tab, verify that Place Map is

set to Once Per Report.

c. In the Geographic Field text box, add the

Customer.Country field.

d. In the Map Values field, add

Customer.Customer Name.

e. Notice that the default summary value

will change to “Count” since this is a

text field.

Students might get a message
to install the map DLL files.

You should have your
installation CD handy just in

case they run into this
problem.
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3. On the Type tab, make the selec-

tions shown in the following

graphic.

a. Select the Type tab and verify that

Ranged is selected.

b. Change Number Of Intervals to 7

c. Verify that Distribution Method is set to

Equal Count.

d. From the Color Of Highest Interval drop-
down list, select Red.

e. From the Color Of Lowest Interval drop-
down list, select White.

4. On the Text tab, set the following

options.

a. Select the Text tab, and if necessary,
delete the text in the Map Title text

box.

b. In the Legend section, verify that Full

Legend is selected.

c. In the Legend Title section, select

Specify.

d. In the Title text box, type Customer
Locations

e. In the Subtitle text box, type By Country

5. Exit the Map Expert dialog box to

apply the settings and preview the

report.

a. Click OK.

b. Preview the report.

c. With the map object selected, position

the mouse over the colored sections of

the map to display a ToolTip.

6. What country has the most customers?

The United States.
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7. Save and close the report. a. Save the report as Customer Locations.
rpt

b. Close the report.
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Due to classroom setup constraints, some labs cannot be keyed in sequence immediately fol-
lowing their associated lesson. Your instructor will tell you whether your labs can be practiced
immediately following the lesson or whether they require separate setup from the main lesson
content.

LESSON 1 LAB 1
Creating Running Totals

Data Files:

• ShippingInfo.rpt

Scenario:
You work for a company that sells bicycles and equipment. As manager of the shipping depart-
ment, you keep a report called ShippingInfo.rpt to track orders. You have been asked how
many orders were shipped via UPS and Federal Express as of May 1, 2002. Create a running
total showing UPS and FedEx shipments. When you’re finished, your report will look like Fig-
ure 1-A. You can also compare your report to the solution file ShippingInfoComplete.rpt.
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Figure 1-A: The completed Shipping Info.rpt report.

1. In ShippingInfo.rpt, create a running total called UPS that summarizes the Ship
Via field using the evaluation formula {Orders.Ship Via}=“UPS”). You will need
to select Ship Via as the field to summarize using the Count function, and evaluate
using the formula {Orders.Ship Via}=“UPS”.

2. Create a running total called FedEx to create a running total for all FedEx
shipments.

3. Add the FedEx and UPS running total fields to the report, under their respec-
tive headings. (Note: Page Header labels have already been placed in the report
for the running totals. Remove the extra field labels as needed.)

4. Preview the report.

As of May 1, there were 58 orders shipped via UPS and 85 orders shipped via Federal

Express.

5. Save and close the file.
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LESSON 2 LAB 1
Building Cross-tabs in Your Report

Scenario:
You work for a company that sells bicycles and equipment. You have been asked to provide a
total count of orders by year, by shipment type, in grid format. Your viewers are particularly
interested in the FedEx and UPS totals, so you have been asked to show those two shipment
carriers first in your grid. When you’re finished, you can compare your report to the Crosstab
Complete.rpt solution file or Figure 2-A.

Figure 2-A: The completed cross-tab.

1. Create a new blank report using the Orders table from the xtreme.mdb file.

2. Create a cross-tab and insert a row heading on the Ship Date field, grouped by
year.

3. Insert a column heading using the Ship Via field.

4. Change the grouping options for the Ship Via field to In Specified Order, pre-
senting FedEx and UPS first, and then all others “in their own groups.”

5. Insert a summary field counting the Order IDs.

6. Place the cross-tab in the report header.

7. If necessary, customize the row headings so that a four-digit year appears.

8. Suppress the row grand totals.

9. Format your cross-tab as desired.

10. Save your report as 2000-02 Shipping.rpt and close it.
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LESSON 3 LAB 1
Adding Subreports

Data Files:

• Orders.rpt

• Credits.rpt

Scenario:
You work for a company that sells bicycles and equipment. You have a report that shows total
customer orders (Orders.rpt) and a separate report that shows total customer credits (Credits.
rpt). You have been asked to display that information in one report, with order totals and credit
totals appearing for each customer side by side. Compare your completed report to Figure 3-A
or the Subreport Comp.rpt solution file.

Figure 3-A: The subreport linked by Customer ID.

1. Open the Orders.rpt file, and increase the size of the Group Header #1 sec-
tion, to make room for the subreport.

2. In the Orders.rpt file, insert the Credits.rpt file as a subreport, linked by Cus-
tomer ID.

3. Modify the Credits.rpt subreport by doing the following:

• Delete Report Header B.

• Delete the group name field.

• Move the remaining fields to the left margin (credit total and detail amount).
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4. Preview the Orders.rpt report. Notice the borders around the subreport’s
information and the spacing problems.

5. Remove the border around the subreport using formatting options.

6. Verify that the Re-import When Opening option is not checked.

7. Edit the subreport to correct spacing problems. (Hint: Remove extra report sec-
tions and suppress remaining sections.)

8. Resize and reposition the subreport so that the credit data appears to the right
of the sales data, and below the Credits heading.

9. Save and close the report.

LESSON 4 LAB 1
Creating a Drill-down

Data Files:

• Employee Salaries.rpt

Scenario:
You work for an engineering firm. You’re creating a report to display the total salary expenses
for each department. Although you don’t need the report to prominently display the salaries for
each employee in each department, you want that data to be accessible from within the report.
The report is named Employee Salaries.rpt.

1. Open the Employee Salaries.rpt file.

2. Group the report by department, so that the department name and total depart-
ment salaries appears for each group. Format the salaries to appear as currency.

3. Hide the Details section so that its contents are only visible via drill-down.
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4. In the Details section, add the First, Last, and Salary fields.

5. Specify that the First, Last, and Salary field labels only display with the drill-
down data.

6. In the Page Header section, add the label Departmental Salary Expenses

7. Preview the drill-down data.

8. Save and close the report.
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LESSON 5 LAB 1
Enhancing Report Processing Using SQL

Scenario:
You work for a company that distributes bicycles and equipment to bike shops around the
world. You want to specify an SQL query to create a report that lists all customers alphabeti-
cally, and includes the largest order amount from each customer. The Customer Name field is
in the Customer table, and the Order Amount field is in the Orders table. Both tables include a
Customer ID field.

1. Create a new, blank report, opening the Add Command option for the
xtreme.mdb database file.

2. Write an SQL statement that will generate the desired report.

3. Move the generated fields onto the report layout, and adjust the formatting as
desired.

4. Save the report as Largest Orders.rpt.

5. Close the report.

LESSON 5 LAB 2
Creating SQL Expression Fields

Data Files:

• Canada Sales.rpt

Scenario:
You want to ensure that the Canada Sales.rpt report data filtering is done on the network
server. You will replace the Orders.Order Date formula with an SQL Expression field.

1. Open the Canada Sales.rpt report.

2. Build an SQL expression called YearFilter that will represent the year of the
order date field enabling filtering to be done at the server level.

3. In the Select Expert, delete the Orders.Order Date formula.
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4. Replace the %YearFilter formula on a new tab that is equal to 2002.

5. Save and close the report.

LESSON 6 LAB 1
Creating Multiple Data Series Charts

Data Files:

• Qtr 1 Canada Sales-Done.rpt

• Qtr 1 Canada Sales.rpt

Scenario:
You work for a company that sells bicycles and equipment. You are meeting with your sales
team to congratulate them on an increase in first quarter sales compared to the previous year.
The sales reps tried some innovative marketing solutions with two customers (Crazy Wheels
and Pedal Pusher Bikes, Inc). You have created a report (Qtr 1 Canada Sales.rpt) that shows
the totals. You know the other sales reps will be more impressed if they can graphically see
the increase in sales for those two customers. When you’re finished, your report should look
like Figure 6-A, or you can compare your work to the Qtr 1 Canada Sales-Done.rpt completion
file. Note: Results will vary depending upon the formatting options selected in step 15.

Figure 6-A: The completed chart in Qtr 1 Canada Sales.rpt.

1. In Qtr 1 Canada Sales.rpt, insert a new report header section to place your
chart.

2. Using the Chart Expert, specify a vertical bar chart.
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3. On the (Advanced) Data tab, move the Order Date and the Customer Name field
to the On Change Of section. Be sure the Order Date field appears above the Cus-
tomer Name field so that the first graphing sort will be done by date.

4. Highlight the Order Date field and confirm the Order settings by clicking the
Order button. Confirm that the order date is grouped by year.

5. Move the Order Amount field to the Show Value(s) section.

6. On the Options tab, in the Data Points section, select Show Value and change the
format to 1K.

7. On the Text tab, change the title to First Quarter Sales.

8. Change the data title to Total Sales.

9. Remove the group title text.

10. Preview your chart.

11. In the Chart Options dialog box, specify that the data labels appear outside the
markers.

12. Change the legend box style to a reverse beveled frame.

13. Change the riser shapes to beveled boxes.

14. Remove gridlines, if desired. Try other formatting changes as desired.

15. Save and close the report.
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LESSON 7 LAB 1
Reporting on Excel Data

Scenario:
You sell books part-time on the side, tracking your sales in an Excel spreadsheet (sales.xls).
You would like to create a summary report showing customer names and total sales with the
ability to double-click the customer name and obtain detail data. When you’re finished, your
report will look like Figure 7-A or you can compare your results to the Customer Book Sales
Practice.rpt completion file.

Figure 7-A: The completed Customer Book Sales Practice.rpt report.

1. Open Sales.xls in Excel and activate the Crystal Report Wizard.

2. Set the report area to be A1 through F31.

3. Create the Crystal Reports report, using all fields, grouped by customer name.

4. Advance through the wizard, not selecting any other options in the tabs pre-
sented until you reach the Add Style To The Report page. Name your report
Customer Book Sales. Select the Executive, Leading Break style.

You would like a total field for each customer, but the report wizard will then force a sort by the total field. You
will therefore not select the title field here, choosing instead to add it to our Crystal Reports report later.
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5. Finish the Expert, preview the report, then exit Excel and open it in Crystal
Reports.

6. Your Customer Book Sales Practice.rpt file will now be open in Crystal Reports.
Remove the field, the line, and the vertical guide indicator from the Group
Footer #1 section. (Tip: Vertical guidelines prohibit you from resizing a section.
Removing the guide indicator will allow us to make the GF1 smaller after you have
created the total.)

7. Right-click the Total field and insert a summary on Group 1.

8. Move the summary field to the Group header to the 3-inch margin position.

9. Suppress the Details section, allowing drill down.

10. Preview your report and format your report as desired to correct any
problems. Steps taken might include:

• Add Details section B.

• Swap Details sections A and B.

• Move page labels into Details section A.

• Suppress each of the page label fields if they are duplicated.

• Set the Suppress Blank Section option on the Details section A.

• Format the sales date format.

• Remove the customer name from the Details section.

LESSON
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alias
An alternative name assigned to a database or
formula.

cross-tab
A report presented in a column and row for-
mat that summarizes and presents data
making it easy to identify trends and compare
data.

DefaultAttribute
A constant used by Crystal Basic formula
syntax.

join
A specification that links two or more tables
together so that data from all the linked tables
can be used within a single report.

multi-pass reporting
The process Crystal Reports uses each time
data is read and manipulated.

null
No value within a database field for a given
record.

on-demand subreport
A subreport that is accessible from the main
report via a link.

running total
A total that is displayed on a record-by-record
basis that totals all records in the report or
group, up to and including the current record.

server-side processing
Sorting, filtering, grouping, and or totaling
report data on the remote server containing
the database, rather than on the client com-
puter accessing the data remotely.

shared variable
Used to pass data around the main report,
back and forth between the main report and
subreports, and from subreport to subreport.

specified order
An order determined by the user.

SQL
Structured Query Language, which is the
standard query language by which people
access and manipulate relational database data
that is stored on a computer network.

SQL aggregate function
A function that produces a single summary
value for a group of values in a specified
field.

SQL clauses
The components of an SQL statement that
you use to indicate the task you want the
database to perform.

SQL expression field
A formula written in SQL rather than in the
Crystal Reports formula language, which you
can use to sort, group, and select data.

SQL statement
A request written using SQL clauses that is
sent to a server containing an SQL database,
and directs the server to perform specific
database tasks.

subquery
A query that is nested inside an outer query.

subreport
A report within a report.
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summarized field
A field that represents a summary such as a
sum, count, or average of multiple values.

template
A set of chart formatting options that can be
used as the starting point for formatting a
new chart.

variable
A value that can change, which is used as
part of a formula.

variable scope
Determines how long and where a variable
keeps its value.
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A
aggregate functions

SQL, 115

alias, 54

aligning objects, 5

B
bar charts, 141

C
charts

creating, 141, 149

formatting, 153, 154

modifying, 145

saving as a template, 159

conditional formulas

suppressing sections, 96

Count function, 77

cross-tabs

creating, 39

creating a specified order, 43

defining, 38

defining a specified order, 43

defining an alias, 54

defining summarized fields, 38

filtering by group, 47

formatting, 51, 54

identifying common formatting options, 50

keeping groups together, 59

planning, 36

using special functions, 55

Crystal Reports Wizard, 165

D
data sources

checking the data, 165

creating a report based on Excel data, 165

modifying a report in Excel, 170

updating an Excel file in Crystal Reports, 173

DefaultAttribute, 55

drill-down

creating, 90

creating separate headings, 96

drill-down level numbering, 96

E
empty sections, 79

Evaluation Time function, 22

Excel

creating a report based on, 165

modifying the report, 170

updating reports, 173

using as a data source, 165

F
formatting options

changing a chart, 153, 154

changing a cross-tab, 51, 54

changing a subreport, 74, 75

identifying, 50

formulas

entering, 9

sharing between main reports and subreports,
78

G
groups

keeping together, 59

J
join types, 120

specifying, 122

joins, 119

specifying with SQL, 121

SQL join types, 120

K
Keep Group Together option, 59
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M
manual running totals

creating on detail data, 18

creating on summary data, 24

maps

creating, 181

inserting, 181

multi-pass reporting, 21, 22

N
null values, 77

O
on-demand subreports

creating, 82

defining, 82

P
PrintDate function, 82

R
Re-import When Opening option, 74, 75

reports

creating using SQL, 111

running total fields

creating, 4, 18, 24

defining, 3

modifying, 8, 9

running totals, 3, 18, 24

S
sections, 79

selecting objects, 5

server-side processing, 104, 132

enabling, 132

shared variables, 78

specified order

creating, 43

defining, 43

SQL, 105

benefits, 106

subqueries, 128

SQL aggregate functions, 115

summarizing report data, 116

SQL clauses, 107

SQL commands

creating, 111

modifying, 111

SQL conventions, 109

SQL expression fields, 131

creating, 132

selecting records, 132

SQL join types, 120

SQL queries

creating a report, 111

viewing in Crystal Reports, 112

SQL rules, 108

SQL statements, 107

subqueries, 128

creating, 128

subreports

creating, 82

defining, 82

editing, 71

formatting, 74, 75

inserting, 65

linking to data in a primary report, 68

planning, 65

sharing formulas, 78

summarized fields, 38

summary operations, 9

suppressing, 79

suppressing sections, 96

T
templates

defining, 158

saving a chart as, 159

Top N charts, 149

V
variable scopes, 78

variables, 17
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